aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-04 13:11:24 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-09 07:56:11 -0700
commit3c4420e55e8ba3859fd5396636bdbce149416249 (patch)
tree21a3fe9600c2f69305df4474c56292e9067a1e1c
parentb32d06fbe797cd39cc19f62bda8a698effe7c0ea (diff)
downloadopenembedded-core-3c4420e55e8ba3859fd5396636bdbce149416249.tar.gz
xuser-account: create separate recipe for xuser creation
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-support/user-creation/xuser-account_0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/user-creation/xuser-account_0.1.bb b/meta/recipes-support/user-creation/xuser-account_0.1.bb
new file mode 100644
index 0000000000..a7575a4ac5
--- /dev/null
+++ b/meta/recipes-support/user-creation/xuser-account_0.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Creates an 'xuser' account"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = ""
+
+inherit allarch useradd
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ :
+}
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system shutdown"
+USERADD_PARAM_${PN} = "--create-home \
+ --groups video,tty,audio,input,shutdown \
+ --user-group xuser"
+
+ALLOW_EMPTY_${PN} = "1"