aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-01 18:17:59 +0100
committerSaul Wold <sgw@linux.intel.com>2013-08-02 08:01:41 -0700
commit2ca75dd0718ec37d7f131b8bcd841de6e876bd07 (patch)
tree2a4190b6eea5f03ae59a3e0c29cffd6433853bfa
parente2cccd73e480318461641d8bc26d538178ff628a (diff)
downloadopenembedded-core-2ca75dd0718ec37d7f131b8bcd841de6e876bd07.tar.gz
grub: disable floating ncurses dependency for GPLv2 version
A dependency was being added on ncurses conditionally upon whether it had been built first. Explicitly disable this dependency to stop this from happening. Note that grub 2.x does not need this same fix because there ncurses is only used when building grub-emu, which is only built when the specified target platform is "emu" which we do not use. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-bsp/grub/grub_0.97.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_0.97.bb b/meta/recipes-bsp/grub/grub_0.97.bb
index 6971193378..38f39121d6 100644
--- a/meta/recipes-bsp/grub/grub_0.97.bb
+++ b/meta/recipes-bsp/grub/grub_0.97.bb
@@ -26,6 +26,8 @@ inherit autotools
COMPATIBLE_HOST = "i.86.*-linux"
+EXTRA_OECONF = "--without-curses"
+
do_install_append_vmware() {
mkdir -p ${D}/boot/
ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub