aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 19:05:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:37:03 +0100
commit1b07bd4c6b1ff70267b97f94b25026a8f8ad3314 (patch)
treee2242ebdd00c2019bb07a8195abda4402f1b7a75
parentd1ec0b64018dafaa6e47233b3465fbe4189e6280 (diff)
downloadopenembedded-core-1b07bd4c6b1ff70267b97f94b25026a8f8ad3314.tar.gz
packagegroup-(base|core-basic): add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved to a separate inc file at some point in the future. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb10
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-basic.bb4
2 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index 217830801d..347a7e15d0 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
LICENSE = "MIT"
-PR = "r75"
+PR = "r76"
inherit packagegroup
@@ -117,12 +117,10 @@ python __anonymous () {
# For backwards compatibility after rename
packages = d.getVar("PACKAGES", True).split()
- packages.remove("packagegroup-distro-base")
- packages.remove("packagegroup-machine-base")
for pkg in packages:
- d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-base", "task-base"))
- d.appendVar("RPROVIDES_packagegroup-distro-base", "task-distro-base")
- d.appendVar("RPROVIDES_packagegroup-machine-base", "task-machine-base")
+ d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-", "task-"))
+ d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-", "task-"))
+ d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-", "task-"))
}
#
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
index 30b66c5b4c..d3eeeedc93 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
@@ -3,7 +3,7 @@
#
DESCRIPTION = "Create Basic Image Tasks"
-PR = "r4"
+PR = "r5"
LICENSE = "MIT"
inherit packagegroup
@@ -24,6 +24,8 @@ python __anonymous () {
packages = d.getVar("PACKAGES", True).split()
for pkg in packages:
d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
+ d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
+ d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
}