aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-08-23 12:26:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:26:00 +0100
commit09e768b68b3605e897d422c9c7b3815f3b994d31 (patch)
treea3172825e17ddd1f77dbc96960247ab9e1af961e
parentad2851cf0abc2ab35e0f60c96d3142c29a07c8fc (diff)
downloadopenembedded-core-09e768b68b3605e897d422c9c7b3815f3b994d31.tar.gz
nativesdk-ca-certificates: prepopulate ca-certificates.crt
As postinsts aren't run for nativesdk packages when populating an SDK, we need to prepopulate up-front. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20130610.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb b/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
index 0692ca2499..29d6ebd38a 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
@@ -60,4 +60,10 @@ pkg_postinst_${PN} () {
CONFFILES_${PN} += "${sysconfdir}/ca-certificates.conf"
+# Postinsts don't seem to be run for nativesdk packages when populating SDKs.
+CONFFILES_${PN}_append_class-nativesdk = " ${sysconfdir}/ssl/certs/ca-certificates.crt"
+do_install_append_class-nativesdk () {
+ SYSROOT="${D}${SDKPATHNATIVE}" update-ca-certificates
+}
+
BBCLASSEXTEND += "native nativesdk"