summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-07-06 17:06:08 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-13 14:06:44 +0800
commitafe58be55b4efc360420a00cbcf60dd5d99ed556 (patch)
tree10663cc3854779f1cbb02bd6f9a38c020c740bdf
parent4ed6b8d256c8485aa16e89deccb86a555e288911 (diff)
downloadopenembedded-core-afe58be55b4efc360420a00cbcf60dd5d99ed556.tar.gz
perl: correct libpth and glibpth
Previouly there is a logic as below used to set libpth in config.sh. libpth='@LIBDIR@ @BASELIBDIR@' But after the below commits introduced, the above logic is dropped. 52f2828314 perl: add a version that builds the recipe using perl-cross, and update to 5.28.1 68552c3532 perl: remove the previous version of the recipe So correct the value of libpth and glibpth to add the dropped logic back to avoid confusing. Before the patch(on 64bits system): # perl -V:libpth libpth='/usr/lib /lib'; After the patch(on 64bits system): # perl -V:libpth libpth='/usr/lib64 /lib64'; Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a494de43c3ccdcf7af988765ae5c3a95bc20c567) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.1.bb b/meta/recipes-devtools/perl/perl_5.32.1.bb
index b28040c7fb..f8893af3e2 100644
--- a/meta/recipes-devtools/perl/perl_5.32.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.1.bb
@@ -62,6 +62,8 @@ do_configure_class-target() {
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
+ -Dlibpth='${libdir} ${base_libdir}' \
+ -Dglibpth='${libdir} ${base_libdir}' \
${PACKAGECONFIG_CONFARGS}
#perl.c uses an ARCHLIB_EXP define to generate compile-time code that