summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiko Mauno <niko.mauno@iki.fi>2018-04-14 09:54:56 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-18 18:48:20 +0100
commitb1600ec8991dfbd3b73d209b9c620a171c5b13c4 (patch)
tree1ae38db898ff546527661fc0c1cd91f2cda1c278
parent11e45082ad00b9c172e59bf6b2a76dd613773f5a (diff)
downloadopenembedded-core-b1600ec8991dfbd3b73d209b9c620a171c5b13c4.tar.gz
run-postinsts: Replace pi_dir variable test
Since commit 5159ddcb62682e1b7e63a20a9218ea96e3fe10a2 string length test performed against pi_dir has effectively never been able to succeed. Change this to rather test if pi_dir is not an existing directory. By doing we remove the chance of seeing the following console error message during first boot to a pristine rootfs: 'ls: /etc/ipk-postinsts: No such file or directory' Signed-off-by: Niko Mauno <niko.mauno@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rwxr-xr-xmeta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts2
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts b/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
index 50c0a1afea..307feb7187 100755
--- a/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
@@ -43,7 +43,7 @@ remove_rcsd_link () {
fi
}
-if [ -z "$pi_dir" ]; then
+if ! [ -d $pi_dir ]; then
remove_rcsd_link
exit 0
fi
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index 31c98ec99c..85b3fc867e 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "Runs postinstall scripts on first boot of the target device"
SECTION = "devel"
-PR = "r9"
+PR = "r10"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"