summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-04-09 11:20:32 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-13 16:55:24 +0100
commit5a88e59e488248b7ec53b072f934052b96c78a51 (patch)
treede08815300d9956eb75bf3c1fe5127668025df3f
parent4612441b59fd8264fdd5bd4f3e5d195f6085c94c (diff)
downloadopenembedded-core-5a88e59e488248b7ec53b072f934052b96c78a51.tar.gz
python3: Add recommended modules to nativesdk install
The python3 installation in the SDK did not include the minimum set of modules to be functional, particularly in the case where Python is brought in through dependencies. Rather than requiring the user to explicitly add the modules, it's better to pull in the modules through RRECOMMENDS. Note that the Python 2 recipe already does this. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.5.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.5.bb b/meta/recipes-devtools/python/python3_3.5.5.bb
index d458d32e60..f893b846ad 100644
--- a/meta/recipes-devtools/python/python3_3.5.5.bb
+++ b/meta/recipes-devtools/python/python3_3.5.5.bb
@@ -211,6 +211,7 @@ py_package_preprocess () {
# manual dependency additions
RPROVIDES_${PN}-modules = "${PN}"
+RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
RRECOMMENDS_${PN}-crypt = "openssl"
RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"