summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-01 00:53:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-02 12:01:09 +0100
commitff1366b0c9db9425d2a29eb823116353f3856dbb (patch)
tree4722d16e80ab284d085fd685956d460b8e8972b4
parent14b7787cfb1318e67ac2721c0d9d5dbf5be9dec4 (diff)
downloadopenembedded-core-ff1366b0c9db9425d2a29eb823116353f3856dbb.tar.gz
glibc: fix a typo
Fixed a typo: name-target-directory -> make-target-directory There is no name-target-directory, it should be make-target-directory, this fixed the error: /bin/bash: /path/to/elf/runtime-linker.T: No such file or directory Makefile:361: recipe for target '/path/to/elf/runtime-linker.st' failed Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/glibc/glibc/elf-Makefile-fix-a-typo.patch36
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc/elf-Makefile-fix-a-typo.patch b/meta/recipes-core/glibc/glibc/elf-Makefile-fix-a-typo.patch
new file mode 100644
index 0000000000..ec480067a8
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc/elf-Makefile-fix-a-typo.patch
@@ -0,0 +1,36 @@
+From 6207fb45553ee98f2f326883b7c21b76c8267343 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Tue, 31 Mar 2015 02:31:25 -0700
+Subject: [PATCH] elf/Makefile: fix a typo
+
+Fixed a typo:
+name-target-directory -> make-target-directory
+
+There is no name-target-directory, it should be make-target-directory,
+this fixed the error:
+/bin/bash: /path/to/elf/runtime-linker.T: No such file or directory
+Makefile:361: recipe for target '/path/to/elf/runtime-linker.st' failed
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ elf/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/elf/Makefile b/elf/Makefile
+index e5b142c..62fe245 100644
+--- a/elf/Makefile
++++ b/elf/Makefile
+@@ -358,7 +358,7 @@ $(objpfx)interp.os: $(elf-objpfx)runtime-linker.h
+
+ $(elf-objpfx)runtime-linker.h: $(elf-objpfx)runtime-linker.st; @:
+ $(elf-objpfx)runtime-linker.st: $(common-objpfx)config.make
+- $(name-target-directory)
++ $(make-target-directory)
+ echo '#define RUNTIME_LINKER "$(rtlddir)/$(rtld-installed-name)"' \
+ > ${@:st=T}
+ $(move-if-change) ${@:st=T} ${@:st=h}
+--
+1.7.9.5
+
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 91feff58ce..fcef4ff3e5 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -25,6 +25,7 @@ SRC_URI = "git://sourceware.org/git/glibc.git;branch=${BRANCH} \
file://0001-Add-unused-attribute.patch \
file://0001-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \
file://0001-yes-within-the-path-sets-wrong-config-variables.patch \
+ file://elf-Makefile-fix-a-typo.patch \
${EGLIBCPATCHES} \
"
EGLIBCPATCHES = "\