summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 12:42:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-04 05:17:15 -0800
commit4066c7a3940df2740ad40b21e3ad517a9af20690 (patch)
tree752495b1bca349004d8caf2b6264a1fd29b5474e
parent8bd88113ec7b962b570cdc90efa9f8b405730677 (diff)
downloadopenembedded-core-4066c7a3940df2740ad40b21e3ad517a9af20690.tar.gz
gnu-config: Only apply path transformations in the non-native/non-nativesdk case
The BUILD_ARCH != TARGET_ARCH check isn't a safe one to detect native builds and doesn't cover the nativesdk case. This converts the recipe to use PN instead which is more accurate and ensures the correct entries making it into the correct packages. (From OE-Core rev: 4a601314604e8428d9dace95c32a71a57eacaaf5) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/gnu-config/gnu-config_20080123.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gnu-config/gnu-config_20080123.bb b/meta/recipes-devtools/gnu-config/gnu-config_20080123.bb
index 94d9d5ebe6..e812ebf0a8 100644
--- a/meta/recipes-devtools/gnu-config/gnu-config_20080123.bb
+++ b/meta/recipes-devtools/gnu-config/gnu-config_20080123.bb
@@ -28,7 +28,7 @@ do_install () {
sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \
-e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
# In the native case we want the system perl as perl-native can't have built yet
- if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
+ if [ "${PN}" != "gnu-config-native" -a "${PN}" != "gnu-config-nativesdk" ]; then
sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize
fi
chmod 755 ${D}${bindir}/gnu-configize