aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
Commit message (Collapse)AuthorAgeFilesLines
* qt5: downgrade to 5.6jansa/pseudoMartin Jansa2019-03-24121-2510/+2407
| | | | | | | | | | | | | | | | | * webosose isn't compatible with newer Qt export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c compile ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra tmp-glibc/work/qemux86-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done in local.conf I have only this to reproduce the failures: PRSERV_HOST = "localhost:0" BB_NUMBER_THREADS = "8" PARALLEL_MAKE = "-j 32" DISTRO_FEATURES_append = " wayland opengl" ERROR_QA_append = " host-user-contaminated" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* qt5: import recipes which often reproduce Yocto #12434 from meta-qt5Martin Jansa2019-03-24102-0/+4388
| | | | | | | | | | * just temporary to make it easier to reproduce, import big part of meta-qt5 * qtquickcontrols-5.9.5+gitAUTOINC+75e9561d4f-r0 do_package_qa: QA Issue: qtquickcontrols: /qtquickcontrols-qmlplugins/usr/lib/qml/QtQuick/Controls/Styles/Base/TreeViewStyle.qml is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=qtquickcontrols; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* qt4: fix-for-mips-n32.patch: remove itRobert Yang2016-01-111-38/+0
| | | | | | | Not needed it any more since qt4 has been moved to meta-qt4. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: remove recipes and classesAlexander Kanavin2016-01-0762-3486/+0
| | | | | | | | | Qt4 is no longer supportd upstream, but it is still needed for LSB compliancy. Qt4 recipes have been moved to a separate meta-qt4 layer to be consistent with meta-qt3 and meta-qt5. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* meta: Drop now pointless manual -dbg packagingRichard Purdie2015-12-161-4/+0
| | | | | | | With the autodebug package generation logic, specifically setting FILES_${PN}-dbg isn't needed in most cases, we can remove them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* package: Add auto package splitting of .debug filesRichard Purdie2015-12-151-0/+1
| | | | | | | | | | | Creating FILES_${PN}-dbg is tedious and also pretty pointless. We might as well assume ".debug" is a special directory name and split into -dbg automatically. This change does so without changing the rest of the splitting logic too much. It can be disabled for the cases where we really do want manual control of the -dbg packages (e.g. qt4) with NOAUTOPACKAGEDEBUG = "1". Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* package_regex.inc: split the rest of the entries to their recipesAlexander Kanavin2015-12-081-0/+2
| | | | | Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* package_regex.inc: split entries which blacklist specific versions to their ↵Alexander Kanavin2015-12-083-0/+10
| | | | | | | recipes Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4-4.8.7: fix build for mips n32Robert Yang2015-12-082-0/+39
| | | | | | | | | | | | | | | | | Issue: LIN8-1720 If _ABIN32 is defined, it should go into 32 bit branch. Fixed: ./wtf/StdLibExtras.h: In instantiation of 'TO WTF::bitwise_cast(FROM) [with TO = int; FROM = double]': runtime/JSValueInlineMethods.h:495:44: required from here ./wtf/Assertions.h:326:47: error: size of array is negative #define COMPILE_ASSERT(exp, name) typedef int dummy##name [(exp) ? 1 : -1] (LOCAL REV: NOT UPSTREAM) -- Sent to oe-core on 20151127 Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: Fix kmap2qmap build with clangKhem Raj2015-09-212-0/+35
| | | | | | | | | | | | | Adapted and backported https://codereview.qt-project.org/#/c/107464/ Fixes errors like ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:161:20: error: call to function 'operator<' that is neither visible in the template definition nor found by argument-dependent lookup return (t1 < t2); Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: remove already merged patchPaul Eggleton2015-09-212-48/+0
| | | | | | | | | This patch was merged into the 4.8.7 release. This was missed on upgrade, and we didn't notice because our quilt-based patch handling code ignores already-applied patches. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* packagegroup-qt*-toolchain-target: fix hard dependency on phonon libraryPaul Eggleton2015-08-241-1/+4
| | | | | | | | Having disabled phonon by default in Qt4 we need to ensure this packagegroup is still buildable when it's not available. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* fotowall: update SRC_URI to use github instead of qt-apps.orgAlexander Kanavin2015-08-111-5/+3
| | | | | | | | GitHub is where upstream development is happening, so we are more likely to find out about new releases from there Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qmmp: Upgrade 0.8.5 -> 0.8.6Jussi Kukkonen2015-08-111-4/+3
| | | | | | | Add a missing runtime dependency. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* nativesdk-qt4-tools: depend on nativesdk-qt4-tools only if DISTRO_FEATURES ↵Pascal Bach2015-07-271-1/+1
| | | | | | | | | | includes x11 Currently nativesdk-qt4-tools can't be built if the DISTRO_FEATURES doesn't contain x11. To make it build we add a dependency to x11 only if the feature is activated. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: fixes for sed commandRobert Yang2015-07-122-9/+2
| | | | | | | | | | | | * There is no $$QT_BUILD_TREE/bin/lrelease in any .pro file, so remove the sed command. * Only translations/translations.pro has "qtPrepareTool(LRELEASE", so use the file name directly rather than find all the .pro files. * The SEDME in linux.conf had been gone in 2010, and no '-Wl,-rpath-link' in linux.conf either, so remove the sed commands. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* meta: Add explict getVar param for (non) expansionRichard Purdie2015-06-231-1/+1
| | | | | | | | | | | | Rather than just use d.getVar(X), use the more explict d.getVar(X, False) since at some point in the future, having the default of expansion would be nice. This is the first step towards that. This patch was mostly made using the command: sed -e 's:\(getVar([^,()]*\)\s*):\1, False):g' -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4-4.8.7: restore arm64 patches which are dropped by mistakeKai Kang2015-06-234-0/+636
| | | | | | | | | | | During upgrade qt4 from 4.8.6 to 4.8.7, four arm64 patches are removed. But three of them are dropped by mistake that they are not merged by upstream and still needed. Restore them. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qmmp: 0.7.7 -> 0.8.5Robert Yang2015-06-111-3/+3
| | | | Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
* qt4: upgrade to 4.8.7Kai Kang2015-06-0844-777/+39
| | | | | | | | | | | | | Upgrade qt4 packages from version 4.8.6 to 4.8.7. * remove arm64 related patches which are merged * remove 0034-Fix-a-division-by-zero-when-processing-malformed-BMP.patch which is backported. * update 0010-configure-Hack-to-not-use-the-pg_config-of-the-host-.patch and 0013-configure-add-crossarch-option.patch for new version * remove useless variable INC_PR Signed-off-by: Kai Kang <kai.kang@windriver.com>
* qt4: unconditionally disable gstreamer 0.10 support in qt webkitAlexander Kanavin2015-05-301-0/+1
| | | | | | | | | | | Previously it was auto-detected in a broken way, which was causing build errors for qt-mobility. Qt4 build will fail if some gstreamer 0.10 packages are available at build time, but not all. It will not fail if none of the packages are available or if all of them are available. We can't guarantee either, hence this patch. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* packagegroup-core-qt4e: make phonon-gstreamer plugin optionalPaul Eggleton2015-05-231-1/+1
| | | | | | | | Having disabled phonon by default in Qt4 we need to ensure this packagegroup is still buildable when it's not available. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: disable Phonon frameworkAlexander Kanavin2015-05-201-2/+2
| | | | | | | | | This allows removal of gstreamer 0.10 dependency from Qt4 recipe https://bugzilla.yoctoproject.org/show_bug.cgi?id=6294 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: remove Qt MobilityAlexander Kanavin2015-05-2012-5442/+0
| | | | | | | | | | | Qt Mobility is an obsolete and unmaintained framework that is also dependent on gstreamer 0.10 https://bugzilla.yoctoproject.org/show_bug.cgi?id=6294 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* packagegroup-core-qt: add x11 to REQUIRED_DISTRO_FEATURESRobert Yang2015-05-141-1/+4
| | | | | | | It can't be built withou x11 in DISTRO_FEATURES. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4-x11-free: make virtual/libgl dependency conditionalDmitry Eremin-Solenikov2015-05-141-1/+2
| | | | | | | | | Make qt4-x11-free depend on virtual/libgl only if the DISTRO_FEATURES contains opengl. Otherwise there will be no package to fullfil this dependency. Signed-off-by: Dmitry Eremin-Solenikov <dmitry_eremin@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4-embedded: add checking for AArch64 ilp32Krishnanjanappa, Jagadeesh2015-05-033-1/+57
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | 1. Cross-compiling qt4-embedded and qt4-x11-free applications for AArch64 ilp32 (both big and little endian) fails with below error, (snip) In file included from ../3rdparty/javascriptcore/JavaScriptCore/runtime/Collector.h:31:0, from ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.h:32, from ../3rdparty/javascriptcore/JavaScriptCore/interpreter/CallFrame.h:26, from ../3rdparty/javascriptcore/JavaScriptCore/runtime/ClassInfo.h:26, from ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSObject.h:27, from ../3rdparty/javascriptcore/JavaScriptCore/API/JSCallbackConstructor.h:30, from ../3rdparty/javascriptcore/JavaScriptCore/API/JSCallbackConstructor.cpp:27: ../3rdparty/javascriptcore/JavaScriptCore/wtf/StdLibExtras.h: In instantiation of 'TO QTWTF::bitwise_cast(FROM) [with TO = int; FROM = double]': ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSImmediate.h:52:49: required from here ../3rdparty/javascriptcore/JavaScriptCore/wtf/StdLibExtras.h:63:1: error: size of array is negative ../3rdparty/javascriptcore/JavaScriptCore/wtf/StdLibExtras.h: In instantiation of 'TO QTWTF::bitwise_cast(FROM) [with TO = double; FROM = int]': ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSImmediate.h:57:47: required from here ../3rdparty/javascriptcore/JavaScriptCore/wtf/StdLibExtras.h:63:1: error: size of array is negative make[1]: *** [obj/release/JSCallbackConstructor.o] Error 1 -- CUT -- the error is because of JSVALUE64 is being defined while compiling programs for AArch64 ilp32. This makes equal condition checking of intptr_t and double datatypes as false, and results in -1 (negative) as array size in bitwise_cast function. The patch defines JSVALUE64, if the programs are being compiled for AArch64 64bit NOT for ilp32. 2. qt4_arch.inc is modified to set system architecture as aarch64 if the TARGET_ARCH is other than aarch64. Without this modification, for TARGET_ARCH equal to aarch64_32, aarch64be, aarch64be_32; the system architecture is set as 'generic' and results in below error. configure log: (snip) 64-bit AMD 80x86 (x86_64) '-opensource' is unsupported, using 'generic' 'x86_64' is supported System architecture: 'generic' Host architecture: 'x86_64' -- CUT -- build error: (snip) In file included from ../../include/QtCore/qatomic_generic.h:1:0, from ../../include/QtCore/../../src/corelib/arch/qatomic_arch.h:64, from ../../include/QtCore/qatomic_arch.h:1, from ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:227, from ../../include/QtCore/qbasicatomic.h:1, from ../../include/QtCore/../../src/corelib/thread/qatomic.h:46, from ../../include/QtCore/qatomic.h:1, from ../../include/QtCore/../../src/corelib/tools/qbytearray.h:45, from ../../include/QtCore/qbytearray.h:1, from ../../include/QtCore/../../src/corelib/tools/qstring.h:46, from ../../include/QtCore/qstring.h:1, from ../../include/QtCore/../../src/corelib/kernel/qobject.h:48, from ../../include/QtCore/qobject.h:1, from ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:45, from ../../include/QtCore/qcoreapplication.h:1, from qdbusintegrator.cpp:42: ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h: In instantiation of 'bool QBasicAtomicPointer<T>::testAndSetOrdered(T*, T*) [with T = const QString]': qdbusintegrator.cpp:76:1: required from here ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h:197:88: error: invalid conversion from 'const void*' to 'void*' [-fpermissive] ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h:108:20: error: initializing argument 2 of 'bool QBasicAtomicPointer_testAndSetOrdered(void* volatile*, void*, void*)' [-fpermissive] ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h:197:88: error: invalid conversion from 'const void*' to 'void*' [-fpermissive] ../../include/QtCore/../../src/corelib/arch/qatomic_generic.h:108:20: error: initializing argument 3 of 'bool QBasicAtomicPointer_testAndSetOrdered(void* volatile*, void*, void*)' [-fpermissive] make[1]: *** [.obj/release-shared-emb-auto/qdbusintegrator.o] Error 1 make[1]: *** Waiting for unfinished jobs.... -- CUT -- So, select system architecture (via QT_ARCH) as aarch64 for AArch64 and its other variants Signed-off-by: Krishnanjanappa, Jagadeesh <jagadeesh.krishnanjanappa@caviumnetworks.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: add patch for BMP denial-of-service vulnerabilityJonathan Liu2015-03-052-0/+45
| | | | | | | | For further details, see: https://bugreports.qt.io/browse/QTBUG-44547 Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt-mobility: Add patch to fix disabling bluez compile issuesRichard Purdie2015-02-192-0/+339
| | | | | | | | If you disable bluez but have dbus enabled, the build would fail. This patch fixes the issue so that bluez5 based builds work. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt-mobility: select distro preference for bluez providerPeter A. Bigot2015-02-171-3/+5
| | | | | | Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* recipes-qt: add x11 to required DISTRO_FEATURESMartin Jansa2015-01-291-0/+4
| | | | | | | | | * it's not complete, but recipes depending on virtual/libx11 are easiest to spot, I've long list of PNBLACKLIST for all recipes which cannot be built in distro without x11 in DISTRO_FEATURES Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* arch-mips.inc: Change definition of TRANSLATED_TARGET_ARCHMark Hatle2015-01-294-4/+4
| | | | | | | | | | | | | | | | | | | | [YOCTO #7230] In certain system configurations TRANSLATED_TARGET_ARCH will not expand in the right order for gcc-cross-candian-mips64n32 to be generated properly. This will cause SDKs to fail to generate properly. Changing the global definition of TRANSLATED_TARGET_ARCH always expands the ABIEXTENSION, which causes the OVERRIDES to pick it up as well. This effectively defines a new class of overrides for the 'n32'. The side effect is that we need to duplicate some mips64 overrides, and redefine others that were previously 'n32' or 'mips64' exclusive to have the correct semantics. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
* meta: set proper S valuePetter Mabäcker2015-01-231-0/+2
| | | | | | | | | | | After removal of auto-creating S we must ensure that all recipes are using a proper value for S. Fix all recipes that only need to set S equals to WORKDIR. [YOCTO #5627] Signed-off-by: Petter Mabäcker <petter@technux.se>
* qt4-embedded: support c++0x stand for directfbHongxu Jia2015-01-162-1/+43
| | | | | | | | | | | | | | | | | | | | While directfd upgrade to 1.7.6, it always includes directfb++ utils when C++ is used and set c++0x as c++ standard. (In git://git.directfb.org/git/directfb/core/DirectFB.git commit b444bcae3197be9faf883460dcc239ef757d5922, and commit 522beeb76f2a8d2dee30d928d2a5955bd06cf25c) The directfd in qt4-embedded is c++, and there was a build failure: ... | qdirectfbwindowsurface.cpp:336:69: error: in C++98 'rect' must be initialized by constructor, not by '{...}' | const DFBRectangle rect = { r.x(), r.y(), r.width(), r.height() }; ... The g++ used c++98 as default c++ standard, we should explicitly set c++0x for directfd in qt4-embedded. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
* qt4: Fix QT4 applications spamming "QWSLock::down(): Invalid argument"Mike Looijmans2015-01-072-0/+99
| | | | | | | | | | | | | | | If you run a QT server application, and a client in a separate process, it will spam the log with "QWSLock::down(): Invalid argument" messages because of an old bug in the locking code. There's a patch on the net that fixes it, which I manually adapted by removing the commented-out debug statements. We have been using this patch for about half a year without problems, and the QT people apparently don't care about the bug, for which this solution has been posted in 2012. Including this into OE core will at least save other people the trouble of having to find and apply it for themselves. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: add aarch64 supportKai Kang2014-12-217-0/+698
| | | | | | | | | | | | | | | | | | | | | | Add aarch64 support for qt4 packages. Most of the patches are derived from debian: http://anonscm.debian.org/cgit/pkg-kde/qt/qt4-x11.git/tree/debian/patches Add arch check to set right QT_ARCH. Disable webkit temporarily for qt4 and qt4-embedded that they fail to build: | runtime/JSValueInlineMethods.h: In constructor 'JSC::JSValue::JSValue(const JSC::JSCell*)': | runtime/JSValueInlineMethods.h:242:78: error: cast from 'JSC::JSCell*' to 'int32_t {aka int}' loses precision [-fpermissive] It has been fix by Qt5, but didn't backport to Qt4. There is an still open defect for it: https://bugreports.qt-project.org/browse/QTBUG-35442 Signed-off-by: Kai Kang <kai.kang@windriver.com>
* qt4: disable webkit for mips64 n32 temporarilyJackie Huang2014-12-051-0/+5
| | | | | | | | | | | | | Disable webkit for mips64 n32 temporarily that fails to compile. The webkit package also disable the build for n32: f5c4d18 webkit/midori: block to build webkit on mips64 with libn32 ABI The opened defect in qt upstream is: https://bugreports.qt-project.org/browse/QTBUG-39224 Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* meta-toolchain-qt: Fix environment populationOtavio Salvador2014-10-101-9/+12
| | | | | | | | | | The generation of the environment has change since the change to use a meta-environment canadian package in the OE-Core, the SDK environment setting has been broken. This uses the new subscript environment to fix it. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* meta-toolchain-qt: fix up old reference to Nokia and typoJonathan Liu2014-09-291-2/+2
| | | | | | | The SDK is now called Qt SDK. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt4: fix bug tracker URLs for patchesJonathan Liu2014-09-292-2/+2
| | | | | Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qt-mobility: fix source URLJonathan Liu2014-09-291-1/+1
| | | | | | | The source is no longer available from the original URL. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* qtdemo-init: Make qtdemo startup correctlyYi Zhao2014-09-291-5/+5
| | | | | | | The qtdemo can't launch via qtdemo-init initscript. Fix it. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* recipes: Remove references to eglibcKhem Raj2014-09-011-1/+1
| | | | | | change use of eglibc related variabled to glibc equivalents Signed-off-by: Khem Raj <raj.khem@gmail.com>
* qt4: Avoid duplicate flags in the g++-unix.confMarek Vasut2014-08-111-23/+2
| | | | | | | | | | The removed flags from this g++.conf file, which is installed to the target as g++-unix.conf are added by gcc-base.conf . Do not add those flags twice. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Eric Bénard <eric@eukrea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* Remove long-deprecated "task-core" backward compat for packagegroups.Robert P. J. Day2014-07-162-10/+0
| | | | | | Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qmmp: upgrade to 0.7.7Hongxu Jia2014-06-171-2/+2
| | | | | | | | | | Build: 1) Add LICENSE_FLAGS_WHITELIST += "commercial" to local.conf 2) bitbake qmmp Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: add patch for GIF denial-of-service vulnerabilityPaul Eggleton2014-06-032-0/+48
| | | | | | | | | For further details, see: https://bugreports.qt-project.org/browse/QTBUG-38367 Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: upgrade to version 4.8.6Paul Eggleton2014-06-0337-375/+15
| | | | | | | | | | * Remove patches merged upstream * Add a qtscript translation package for an additional .qm file added in this release Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* qt4: Explicitly disable sqlite2Martin Jansa2014-05-061-1/+1
| | | | | | | | | | | | | | * notice that this disables only sqlite2 (sqlite dependency), sqlite (sqlite3 dependency) stays enabled * fixes these errors detected by test-dependencies.sh: qt4-embedded/qt4-embedded-plugin-sqldriver-sqlite2/latest doesn't exist qt4-embedded/qt4-embedded-plugin-sqldriver-sqlite2-dbg/latest doesn't exist qt4-x11-free/qt4-plugin-sqldriver-sqlite2/latest doesn't exist qt4-x11-free/qt4-plugin-sqldriver-sqlite2-dbg/latest doesn't exist Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
* Globally replace 'base_contains' calls with 'bb.utils.contains'Otavio Salvador2014-04-256-11/+11
| | | | | | | | | The base_contains is kept as a compatibility method and we ought to not use it in OE-Core so we can remove it from base metadata in future. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>