aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/build-appliance-image.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/images/build-appliance-image.bb b/meta/recipes-core/images/build-appliance-image.bb
index 59ccb98b02..80cbbecd4b 100644
--- a/meta/recipes-core/images/build-appliance-image.bb
+++ b/meta/recipes-core/images/build-appliance-image.bb
@@ -68,11 +68,11 @@ fakeroot do_populate_poky_src () {
IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
-python do_get_poky_src () {
- bb.build.exec_func('base_do_fetch', d)
- bb.build.exec_func('base_do_unpack', d)
+python () {
+ # Ensure we run these usually noexec tasks
+ d.delVarFlag("do_fetch", "noexec")
+ d.delVarFlag("do_unpack", "noexec")
}
-addtask do_get_poky_src before do_rootfs
create_bundle_files () {
cd ${WORKDIR}