summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/pmloglib/pmloglib-private.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-webos/pmloglib/pmloglib-private.bb')
-rw-r--r--meta/recipes-webos/pmloglib/pmloglib-private.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-webos/pmloglib/pmloglib-private.bb b/meta/recipes-webos/pmloglib/pmloglib-private.bb
new file mode 100644
index 0000000000..db974af200
--- /dev/null
+++ b/meta/recipes-webos/pmloglib/pmloglib-private.bb
@@ -0,0 +1,25 @@
+# Copyright (c) 2013-2018 LG Electronics, Inc.
+
+SUMMARY = "webOS logging library - private interface"
+AUTHOR = "Anatolii Sakhnik <anatolii.sakhnik@lge.com>"
+SECTION = "webos/libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+WEBOS_VERSION = "3.3.0-1_1de57d269d4c6cc2dba93c4683acc22cbc2ecb35"
+PR = "r1"
+
+inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_pkgconfig
+
+# B needs to be different from that of pmloglib so there's
+# no collision in the case of local development.
+B = "${S}/build-private"
+EXTRA_OECMAKE += "-DBUILD_PRIVATE=ON"
+
+WEBOS_REPO_NAME = "pmloglib"
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"