aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch19
-rw-r--r--meta/recipes-support/gmp/gmp-6.1.2/amd64.patch10
-rw-r--r--meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch14
3 files changed, 20 insertions, 23 deletions
diff --git a/meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch b/meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch
index 665367658b..1e47924ccc 100644
--- a/meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch
+++ b/meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch
@@ -18,13 +18,13 @@ Upstream-Status: Inappropriate[OE-Specific]
configure.ac | 11 -----------
1 file changed, 11 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 857ea3b..359e919 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -607,15 +607,6 @@ case $host in
- GMP_INCLUDE_MPN(arm/arm-defs.m4)
- CALLING_CONVENTIONS_OBJS='arm32call.lo arm32check.lo'
+Index: gmp-6.1.2/configure.ac
+===================================================================
+--- gmp-6.1.2.orig/configure.ac
++++ gmp-6.1.2/configure.ac
+@@ -604,15 +604,6 @@ case $host in
+ any_32_testlist="sizeof-long-4"
+ any_64_testlist="sizeof-long-8"
- # This is needed for clang, which is not content with flags like -mfpu=neon
- # alone.
@@ -38,7 +38,7 @@ index 857ea3b..359e919 100644
# FIXME: We make mandatory compiler options optional here. We should
# either enforce them, or organise to strip paths as the corresponding
# options fail.
-@@ -686,8 +677,6 @@ case $host in
+@@ -746,8 +737,6 @@ case $host in
;;
*)
path="arm"
@@ -47,6 +47,3 @@ index 857ea3b..359e919 100644
;;
esac
;;
---
-1.9.1
-
diff --git a/meta/recipes-support/gmp/gmp-6.1.2/amd64.patch b/meta/recipes-support/gmp/gmp-6.1.2/amd64.patch
index 564d12d42b..3935589f8b 100644
--- a/meta/recipes-support/gmp/gmp-6.1.2/amd64.patch
+++ b/meta/recipes-support/gmp/gmp-6.1.2/amd64.patch
@@ -1,10 +1,10 @@
Upstream-Status: Pending
-Index: gmp-5.0.3/longlong.h
+Index: gmp-6.1.2/longlong.h
===================================================================
---- gmp-5.0.3.orig/longlong.h
-+++ gmp-5.0.3/longlong.h
-@@ -994,8 +994,10 @@ extern UWtype __MPN(udiv_qrnnd) _PROTO (
+--- gmp-6.1.2.orig/longlong.h
++++ gmp-6.1.2/longlong.h
+@@ -1036,8 +1036,10 @@ extern UWtype __MPN(udiv_qrnnd) (UWtype
count is only an int. */
#define count_trailing_zeros(count, x) \
do { \
@@ -14,5 +14,5 @@ Index: gmp-5.0.3/longlong.h
+ __asm__ ("bsfq %1,%0" : "=r" (__cbtmp) : "rm" ((UDItype)(x))); \
+ (count) = __cbtmp; \
} while (0)
- #endif /* x86_64 */
+ #endif /* __amd64__ */
diff --git a/meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch b/meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch
index 74904a2530..6b089cf39c 100644
--- a/meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch
+++ b/meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch
@@ -1,15 +1,15 @@
Upstream-Status: Pending
-Index: gmp-4.2.4/Makefile.am
+Index: gmp-6.1.2/Makefile.am
===================================================================
---- gmp-4.2.4.orig/Makefile.am 2008-09-10 19:31:27.000000000 +0000
-+++ gmp-4.2.4/Makefile.am 2009-07-06 20:19:19.000000000 +0000
-@@ -106,7 +106,7 @@
- # but anyone knowledgable enough to be playing with exec_prefix will be able
+--- gmp-6.1.2.orig/Makefile.am
++++ gmp-6.1.2/Makefile.am
+@@ -130,7 +130,7 @@ EXTRA_DIST += gmpxx.h
+ # but anyone knowledgeable enough to be playing with exec_prefix will be able
# to address that.
#
-includeexecdir = $(exec_prefix)/include
+includeexecdir = $(includedir)
include_HEADERS = $(GMPXX_HEADERS_OPTION)
- nodist_includeexec_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
- lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)
+ nodist_includeexec_HEADERS = gmp.h
+ lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION)