summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/xxhash/xxhash_0.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/xxhash/xxhash_0.8.0.bb')
-rw-r--r--meta/recipes-support/xxhash/xxhash_0.8.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/xxhash/xxhash_0.8.0.bb b/meta/recipes-support/xxhash/xxhash_0.8.0.bb
new file mode 100644
index 0000000000..4e48365a71
--- /dev/null
+++ b/meta/recipes-support/xxhash/xxhash_0.8.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Extremely fast non-cryptographic hash algorithm"
+DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
+working at speeds close to RAM limits."
+HOMEPAGE = "http://www.xxhash.com/"
+LICENSE = "BSD-2-Clause & GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b335320506abb0505437e39295e799cb"
+
+SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=git \
+ file://0001-Makefile-escape-special-regex-characters-in-paths.patch \
+ "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+SRCREV = "94e5f23e736f2bb67ebdf90727353e65344f9fc0"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+ oe_runmake all
+}
+
+do_install () {
+ oe_runmake DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native nativesdk"