aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.44.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vte/vte_0.44.1.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.44.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.44.1.bb b/meta/recipes-support/vte/vte_0.44.1.bb
new file mode 100644
index 0000000000..ecbf58a900
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.44.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Virtual terminal emulator GTK+ widget library"
+BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "glib-2.0 gtk+3 intltool-native"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+inherit gnomebase gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
+
+SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch"
+SRC_URI[archive.md5sum] = "20916d97a5902657e54307cc2757beee"
+SRC_URI[archive.sha256sum] = "712dd548339f600fd7e221d12b2670a13a4361b2cd23ba0e057e76cc19fe5d4e"
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+# Enable vala only if gobject-introspection is enabled
+EXTRA_OECONF = "--enable-vala=auto"
+
+# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
+# Use libtool-cross (which has a hack to prevent that) instead.
+EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
+
+PACKAGES =+ "libvte"
+FILES_libvte = "${libdir}/*.so.*"