aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch')
-rw-r--r--meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch101
1 files changed, 0 insertions, 101 deletions
diff --git a/meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch b/meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch
deleted file mode 100644
index ccad0a1a14..0000000000
--- a/meta/recipes-support/nspr/nspr/fix-build-on-aarch64.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-Add Aarch64 support
-
-Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
-
-Upstream-Status: Submitted https://bugzilla.mozilla.org/show_bug.cgi?id=827271
----
- configure.in | 12 ++++++------
- 1 files changed, 6 insertions(+), 6 deletions(-)
---- a/pr/include/md/_linux.cfg
-+++ b/pr/include/md/_linux.cfg
-@@ -861,6 +861,59 @@
- #define PR_BYTES_PER_WORD_LOG2 2
- #define PR_BYTES_PER_DWORD_LOG2 3
-
-+#elif defined(__aarch64__)
-+
-+#ifdef __AARCH64EB__
-+#undef IS_LITTLE_ENDIAN
-+#define IS_BIG_ENDIAN 1
-+#elif defined(__AARCH64EL__)
-+#define IS_LITTLE_ENDIAN 1
-+#undef IS_BIG_ENDIAN
-+#else
-+#error "Unknown Aarch64 endianness."
-+#endif
-+#define IS_64
-+
-+#define PR_BYTES_PER_BYTE 1
-+#define PR_BYTES_PER_SHORT 2
-+#define PR_BYTES_PER_INT 4
-+#define PR_BYTES_PER_INT64 8
-+#define PR_BYTES_PER_LONG 8
-+#define PR_BYTES_PER_FLOAT 4
-+#define PR_BYTES_PER_DOUBLE 8
-+#define PR_BYTES_PER_WORD 8
-+#define PR_BYTES_PER_DWORD 8
-+
-+#define PR_BITS_PER_BYTE 8
-+#define PR_BITS_PER_SHORT 16
-+#define PR_BITS_PER_INT 32
-+#define PR_BITS_PER_INT64 64
-+#define PR_BITS_PER_LONG 64
-+#define PR_BITS_PER_FLOAT 32
-+#define PR_BITS_PER_DOUBLE 64
-+#define PR_BITS_PER_WORD 64
-+
-+#define PR_BITS_PER_BYTE_LOG2 3
-+#define PR_BITS_PER_SHORT_LOG2 4
-+#define PR_BITS_PER_INT_LOG2 5
-+#define PR_BITS_PER_INT64_LOG2 6
-+#define PR_BITS_PER_LONG_LOG2 6
-+#define PR_BITS_PER_FLOAT_LOG2 5
-+#define PR_BITS_PER_DOUBLE_LOG2 6
-+#define PR_BITS_PER_WORD_LOG2 6
-+
-+#define PR_ALIGN_OF_SHORT 2
-+#define PR_ALIGN_OF_INT 4
-+#define PR_ALIGN_OF_LONG 8
-+#define PR_ALIGN_OF_INT64 8
-+#define PR_ALIGN_OF_FLOAT 4
-+#define PR_ALIGN_OF_DOUBLE 8
-+#define PR_ALIGN_OF_POINTER 8
-+#define PR_ALIGN_OF_WORD 8
-+
-+#define PR_BYTES_PER_WORD_LOG2 3
-+#define PR_BYTES_PER_DWORD_LOG2 3
-+
- #else
-
- #error "Unknown CPU architecture"
---- a/pr/include/md/_linux.h
-+++ b/pr/include/md/_linux.h
-@@ -53,6 +53,8 @@
- #define _PR_SI_ARCHITECTURE "avr32"
- #elif defined(__m32r__)
- #define _PR_SI_ARCHITECTURE "m32r"
-+#elif defined(__aarch64__)
-+#define _PR_SI_ARCHITECTURE "aarch64"
- #else
- #error "Unknown CPU architecture"
- #endif
-@@ -186,7 +188,7 @@
- })
- #endif
-
--#if defined(__arm__)
-+#if defined(__arm__) || defined(__aarch64__)
- #if defined(__GCC_HAVE_SYNC_COMPARE_AND_SWAP_4)
- /* Use GCC built-in functions */
- #define _PR_HAVE_ATOMIC_OPS
-@@ -242,6 +244,10 @@
- #endif
- #endif /* __arm__ */
-
-+#if defined(__aarch64__)
-+#define _MD_MINIMUM_STACK_SIZE 0x20000
-+#endif
-+
- #define USE_SETJMP
- #if (defined(__GLIBC__) && __GLIBC__ >= 2) || defined(ANDROID)
- #define _PR_POLL_AVAILABLE