summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgit2/libgit2_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgit2/libgit2_1.5.1.bb')
-rw-r--r--meta/recipes-support/libgit2/libgit2_1.5.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-support/libgit2/libgit2_1.5.1.bb b/meta/recipes-support/libgit2/libgit2_1.5.1.bb
new file mode 100644
index 0000000000..59866ce385
--- /dev/null
+++ b/meta/recipes-support/libgit2/libgit2_1.5.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT & OpenSSL & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=112e6bb421dea73cd41de09e777f2d2c"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.5;protocol=https"
+SRCREV = "42e5db98b963ae503229c63e44e06e439df50e56"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DREGEX_BACKEND='pcre2' \
+"
+
+BBCLASSEXTEND = "native"