summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch')
-rw-r--r--meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch b/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
new file mode 100644
index 0000000000..55872aa8fa
--- /dev/null
+++ b/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
@@ -0,0 +1,52 @@
+From 897900f3f9084c5542097851323bba3f2691df20 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 15 Jan 2020 17:16:28 +0100
+Subject: [PATCH] tests: do not statically link a test
+
+This fails on e.g. centos 7
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ progs/Makefile | 2 +-
+ tests/Makefile | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/progs/Makefile b/progs/Makefile
+index 3e82862..48533f3 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -49,7 +49,7 @@ capsh: capsh.c capshdoc.h.cf $(DEPS)
+ $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS)
+
+ tcapsh-static: capsh.c capshdoc.h.cf $(DEPS)
+- $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS) --static
++ $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS)
+
+ uns_test: ../tests/uns_test.c
+ $(MAKE) -C ../tests uns_test
+diff --git a/tests/Makefile b/tests/Makefile
+index 4a5f2f9..4266d86 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -22,7 +22,7 @@ ifeq ($(PTHREADS),yes)
+ DEPS += ../libcap/libpsx.so
+ endif
+ else
+-LDFLAGS += --static
++LDFLAGS +=
+ DEPS=../libcap/libcap.a
+ ifeq ($(PTHREADS),yes)
+ DEPS += ../libcap/libpsx.a
+@@ -113,7 +113,7 @@ noexploit: exploit.o $(DEPS)
+
+ # This one runs in a chroot with no shared library files.
+ noop: noop.c
+- $(CC) $(CFLAGS) $< -o $@ --static
++ $(CC) $(CFLAGS) $< -o $@
+
+ clean:
+ rm -f psx_test libcap_psx_test libcap_launch_test uns_test *~
+--
+2.25.1
+