summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch')
-rw-r--r--meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch b/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch
new file mode 100644
index 0000000000..ba332527f1
--- /dev/null
+++ b/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch
@@ -0,0 +1,59 @@
+Upstream-Status: Rejected
+
+Add pkgconfig support to libassuan.
+This patch is rejected by upstream for the reason below:
+They think pkgconfig adds no portability and maintaining them is not worthwhile.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Index: Makefile.am
+==============================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -21,11 +21,14 @@
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = assuan.pc
++
+ EXTRA_DIST = config.rpath autogen.sh README.GIT \
+ ChangeLog-2011 doc/ChangeLog-2011 src/ChangeLog-2011 \
+ tests/ChangeLog-2011 contrib/ChangeLog-2011 \
+ build-aux/gitlog-to-changelog build-aux/git-log-footer \
+- build-aux/git-log-fix
++ build-aux/git-log-fix assuan.pc.in
+
+ SUBDIRS = m4 src doc tests
+
+Index: assuan.pc.in
+==============================================================
+--- /dev/null
++++ b/assuan.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libassuan
++Description: IPC library used by GnuPG and GPGME
++Requires:
++Version: @VERSION@
++Libs: -L${libdir} -lassuan
++Libs.private: -lgpg-error
++Cflags: -I${includedir}
+Index: configure.ac
+==============================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -380,5 +380,5 @@ AC_CONFIG_FILES([doc/Makefile])
+ AC_CONFIG_FILES([tests/Makefile])
+ AC_CONFIG_FILES([src/libassuan-config], [chmod +x src/libassuan-config])
+ AC_CONFIG_FILES([src/versioninfo.rc])
+-
++AC_CONFIG_FILES([assuan.pc])
+ AC_OUTPUT
+--
+1.7.5.4
+