summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch48
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb1
2 files changed, 0 insertions, 49 deletions
diff --git a/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch b/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch
deleted file mode 100644
index 89aa1587c1..0000000000
--- a/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 72f2e9043ef509992dfa61791638db87bf0ae37b Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 6 Dec 2016 01:20:00 +0000
-Subject: [PATCH] Clarify conditions to avoid compiler errors
-
-Fix errors pointed out by clang
-
-error: logical not is only applied to the left hand side of this bitwise operator [-Werror,-Wlogical-not-parentheses]
-| if (only_immutable && !copy->flags[i] & FLAG_IMMUTABLE) continue;
-| ^
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Submitted
-
- signpost.c | 2 +-
- tracks.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/signpost.c b/signpost.c
-index aa2e13a..2e2dff2 100644
---- a/signpost.c
-+++ b/signpost.c
-@@ -284,7 +284,7 @@ static int check_nums(game_state *orig, game_state *copy, int only_immutable)
- int i, ret = 1;
- assert(copy->n == orig->n);
- for (i = 0; i < copy->n; i++) {
-- if (only_immutable && !copy->flags[i] & FLAG_IMMUTABLE) continue;
-+ if (only_immutable && !(copy->flags[i] & FLAG_IMMUTABLE)) continue;
- assert(copy->nums[i] >= 0);
- assert(copy->nums[i] <= copy->n);
- if (copy->nums[i] != orig->nums[i]) {
-diff --git a/tracks.c b/tracks.c
-index 5b27350..ca44ce1 100644
---- a/tracks.c
-+++ b/tracks.c
-@@ -1072,7 +1072,7 @@ static int solve_check_single_sub(game_state *state, int si, int id, int n,
- x = i%w;
- y = i/w;
- if (abs(ox-x) > 1 || abs(oy-y) > 1) {
-- if (!state->sflags[i] & S_TRACK)
-+ if (!(state->sflags[i] & S_TRACK))
- did += solve_set_sflag(state, x, y, S_NOTRACK, what);
- }
- }
---
-1.9.1
-
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
index 6148e40ada..6574e1dba4 100644
--- a/meta/recipes-sato/puzzles/puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -13,7 +13,6 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
file://fix-compiling-failure-with-option-g-O.patch \
file://0001-Use-labs-instead-of-abs.patch \
file://0001-palisade-Fix-warnings-with-clang-on-arm.patch \
- file://0001-Clarify-conditions-to-avoid-compiler-errors.patch \
file://0001-Use-Wno-error-format-overflow-if-the-compiler-suppor.patch \
"
UPSTREAM_CHECK_COMMITS = "1"