aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb')
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
new file mode 100644
index 0000000000..92f0ee17db
--- /dev/null
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices"
+HOMEPAGE = "http://www.o-hand.com"
+BUGTRACKER = "http://bugzilla.yoctoproject.org/"
+
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
+ file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
+
+DEPENDS = "matchbox-panel-2 gtk+3"
+
+# SRCREV tagged 0.2
+SRCREV = "5db2672fb857b2c80b949d8fce92e0f0029cc947"
+SRC_URI = "git://git.yoctoproject.org/screenshot"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig distro_features_check
+
+FILES_${PN} += "${libdir}/matchbox-panel/*.so"
+
+do_install_append () {
+ rm ${D}${libdir}/matchbox-panel/*.la
+}
+
+# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"