aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
index d6c53b003c..d9a2f22147 100644
--- a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.1.bb
@@ -12,7 +12,9 @@ SECTION = "x11/wm"
# SRCREV tagged 2.1
SRCREV = "c8473519a0f37488b8b3e839e275b000cdde0b80"
-SRC_URI = "git://git.yoctoproject.org/${BPN}-2"
+SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \
+ file://vfolders/* \
+ "
EXTRA_OECONF = "--enable-startup-notification --with-dbus"
@@ -22,3 +24,10 @@ inherit autotools pkgconfig distro_features_check
# The startup-notification requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
+
+do_install_append() {
+ install -d ${D}${datadir}/matchbox/vfolders/
+ install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
+}
+
+FILES_${PN} += "${datadir}/matchbox/vfolders/"