summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtwayland-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt5/qtwayland-native_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtwayland-native_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qtwayland-native_git.bb b/meta/recipes-qt/qt5/qtwayland-native_git.bb
new file mode 100644
index 0000000000..4a4c605f8a
--- /dev/null
+++ b/meta/recipes-qt/qt5/qtwayland-native_git.bb
@@ -0,0 +1,30 @@
+require qt5-native.inc
+require qt5-git.inc
+
+# There are no LGPLv3-only licensed files in this component.
+LICENSE = "BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
+ file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
+ file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
+ file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+DEPENDS = "qtbase-native wayland-native"
+
+# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.6-native
+# 5.6.meta-qt5-native.1
+SRC_URI += " \
+ file://0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch \
+"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S}/src/qtwaylandscanner
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
+
+SRCREV = "70575643cfece4f0aca4b40e77ac5d7c0e8042a2"