summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtsystems_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt5/qtsystems_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtsystems_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qtsystems_git.bb b/meta/recipes-qt/qt5/qtsystems_git.bb
new file mode 100644
index 0000000000..0bda2e9970
--- /dev/null
+++ b/meta/recipes-qt/qt5/qtsystems_git.bb
@@ -0,0 +1,34 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+ file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+"
+
+DEPENDS += "qtbase qtdeclarative udev gconf"
+
+inherit bluetooth
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
+
+EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
+
+do_configure_prepend() {
+ # disable bluez test if it isn't enabled by PACKAGECONFIG
+ sed -i 's/^ qtCompileTest(bluez)/ OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtsystems.pro
+}
+
+do_install_append() {
+ # Remove example.pro file as it is useless
+ rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro
+}
+
+QT_MODULE_BRANCH = "dev"
+
+SRCREV = "66e45676f5f5c6251ccab36906c6324fd0065e08"