summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtbase-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt5/qtbase-native_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtbase-native_git.bb92
1 files changed, 38 insertions, 54 deletions
diff --git a/meta/recipes-qt/qt5/qtbase-native_git.bb b/meta/recipes-qt/qt5/qtbase-native_git.bb
index 36eeae8936..ee1de4d8f3 100644
--- a/meta/recipes-qt/qt5/qtbase-native_git.bb
+++ b/meta/recipes-qt/qt5/qtbase-native_git.bb
@@ -2,15 +2,10 @@ DESCRIPTION = "Native version of Qt/[X11|Mac|Embedded]"
DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://qt-project.org"
-
-LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://LICENSE.LGPLv21;md5=fb91571854638f10b2e5f36562661a5a \
file://LICENSE.LGPLv3;md5=a909b94c1c9674b2aa15ff03a86f518a \
- file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
@@ -20,45 +15,41 @@ require qt5-native.inc
require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.10-shared
-# 5.10.meta-qt5-shared.2
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.6-shared
+# 5.6.meta-qt5-shared.9
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
- file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
- file://0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
- file://0004-configure-bump-path-length-from-256-to-512-character.patch \
- file://0005-Disable-all-unknown-features-instead-of-erroring-out.patch \
- file://0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
- file://0007-Delete-qlonglong-and-qulonglong.patch \
- file://0008-Replace-pthread_yield-with-sched_yield.patch \
- file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
- file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
- file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
- file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
+ file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
+ file://0003-Add-external-hostbindir-option.patch \
+ file://0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch \
+ file://0005-configure-bump-path-length-from-256-to-512-character.patch \
+ file://0006-QOpenGLPaintDevice-sub-area-support.patch \
+ file://0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
+ file://0008-configure-paths-for-target-qmake-properly.patch \
+ file://0009-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
"
# common for qtbase-native and nativesdk-qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.10-native
-# 5.10.meta-qt5-native.2
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.6-native
+# 5.6.meta-qt5-native.9
SRC_URI += " \
- file://0013-Always-build-uic-and-qvkgen.patch \
-"
-
-# only for qtbase-native
-SRC_URI += " \
- file://0014-Bootstrap-without-linkat-feature.patch \
+ file://0010-Always-build-uic.patch \
+ file://0011-Add-external-hostbindir-option-for-native-sdk.patch \
"
CLEANBROKEN = "1"
-XPLATFORM_toolchain-clang = "linux-oe-clang"
-XPLATFORM ?= "linux-oe-g++"
+QT_CONF_PATH = "${B}/qt.conf"
+
+do_generate_qt_config_file() {
+ :
+}
PACKAGECONFIG_CONFARGS = " \
+ -prefix ${prefix} \
-sysroot ${STAGING_DIR_NATIVE} \
-no-gcc-sysroot \
-system-zlib \
- -qt-pcre \
-no-libjpeg \
-no-libpng \
-no-gif \
@@ -75,15 +66,11 @@ PACKAGECONFIG_CONFARGS = " \
-verbose \
-release \
-prefix ${OE_QMAKE_PATH_PREFIX} \
- -hostprefix ${OE_QMAKE_PATH_PREFIX} \
-bindir ${OE_QMAKE_PATH_BINS} \
- -hostbindir ${OE_QMAKE_PATH_BINS} \
-libdir ${OE_QMAKE_PATH_LIBS} \
- -hostlibdir ${OE_QMAKE_PATH_LIBS} \
-headerdir ${OE_QMAKE_PATH_HEADERS} \
-archdatadir ${OE_QMAKE_PATH_ARCHDATA} \
-datadir ${OE_QMAKE_PATH_DATA} \
- -hostdatadir ${QMAKE_MKSPEC_PATH_NATIVE} \
-docdir ${OE_QMAKE_PATH_DOCS} \
-sysconfdir ${OE_QMAKE_PATH_SETTINGS} \
-no-glib \
@@ -92,24 +79,23 @@ PACKAGECONFIG_CONFARGS = " \
-nomake examples \
-nomake tests \
-no-rpath \
- -no-feature-linkat \
- -platform ${XPLATFORM} \
+ -platform linux-oe-g++ \
"
-# for qtbase configuration we need default settings
-# since we cannot set empty set filename to a not existent file
-deltask generate_qt_config_file
+# qtbase is exception, configure script is using our get(X)QEvalMakeConf and setBootstrapEvalVariable functions to read it from shell
+export OE_QMAKE_COMPILER
+export OE_QMAKE_CC
+export OE_QMAKE_CFLAGS
+export OE_QMAKE_CXX
+export OE_QMAKE_CXXFLAGS
+export OE_QMAKE_LINK
+export OE_QMAKE_LDFLAGS
+export OE_QMAKE_AR
+export OE_QMAKE_STRIP
do_configure_prepend() {
- # Regenerate header files when they are included in source tarball
- # Otherwise cmake files don't set PRIVATE_HEADERS correctly
- rm -rf ${S}/include
- mkdir -p ${S}/.git || true
-
- # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
- touch ${S}/mkspecs/oe-device-extra.pri
-
- MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -${QT_EDITION} -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
+ MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
+ bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
}
do_install() {
@@ -130,11 +116,9 @@ do_install() {
done
fi
- install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
-
- # since 5.9.2 something sets a very strange path to mkspec ("${_qt5Core_install_prefix}/../../../../../../../../../../usr/lib/qt5//mkspecs/linux-oe-g++")
- # override this until somebody finds a better way
- echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
+ # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
+ # e.g. qt3d, qtwayland
+ ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
-SRCREV = "6c6ace9d23f90845fd424e474d38fe30f070775e"
+SRCREV = "e6f8b072d2bf15f8b82bede48ff29ce8ac8dbd9a"