summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb b/meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
new file mode 100644
index 0000000000..383145beb3
--- /dev/null
+++ b/meta/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "This driver extends Qt's platform support (QPA) for Virtualbox guests. \
+It uses the integrated pointer feature to create a smooth conversion from \
+the host pointer to touchscreen events in the guest, without grabbing the \
+host pointer."
+SUMMARY = "Touchscreen driver for integrated mouse pointer in VirtualBox"
+LICENSE = "LGPL-2.1 & GPL-3.0"
+LIC_FILES_CHKSUM = " \
+ file://vboxtouch.cpp;beginline=1;endline=22;md5=ca51db8f7c0606c77f702dcee4cf31d9 \
+ file://evdevmousehandler.cpp;beginline=1;endline=40;md5=9081062f6e7f74b6e62ad7ecee4a71be \
+"
+
+PV = "1.1.4+gitr${SRCPV}"
+
+DEPENDS = "qtbase"
+
+# Needed with gcc-5.2 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65801
+CXXFLAGS += "-Wno-narrowing"
+
+SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git"
+SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb"
+S = "${WORKDIR}/git/vboxtouch"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/generic/libvboxtouchplugin.so"
+FILES_${PN}-dbg += "${OE_QMAKE_PATH_PLUGINS}/generic/.debug/"
+FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/cmake/*"