summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt-4.7.4.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt4/qt-4.7.4.inc')
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.4.inc9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.7.4.inc b/meta/recipes-qt/qt4/qt-4.7.4.inc
index 5c06bbe0cb..bc33b6b1b8 100644
--- a/meta/recipes-qt/qt4/qt-4.7.4.inc
+++ b/meta/recipes-qt/qt4/qt-4.7.4.inc
@@ -13,6 +13,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://0009-support-2bpp.patch \
file://0001-Added-Openembedded-crossarch-option.patch \
file://blacklist-diginotar-certs.diff \
+ file://fix-translations.patch \
file://g++.conf \
file://linux.conf \
file://fix-qtbug-20925.patch \
@@ -27,7 +28,9 @@ FILES_${QT_BASE_NAME}-tools += "${bindir}/qml"
do_configure_prepend() {
for pro in $(find ${S} -name "*.pro") ; do
- sed -i 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' $pro
+ sed -i \
+ -e 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' \
+ -e 's:qtPrepareTool(LRELEASE, lrelease):LRELEASE = ${OE_QMAKE_LRELEASE}:g' $pro
done
sed -i s:SEDME:${S}: ${WORKDIR}/linux.conf
@@ -39,10 +42,6 @@ do_configure_prepend() {
${S}/configure
}
-do_configure_append() {
- sed -e '/QMAKE_TARGET /d' -e '/TARGET /d' -i ${S}/translations/Makefile
-}
-
QT_GLFLAGS ?= ""
QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"