summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt-apps')
-rw-r--r--meta/recipes-qt/qt-apps/fotowall_0.9.bb19
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.4.1.bb32
-rw-r--r--meta/recipes-qt/qt-apps/quicky_0.4.bb16
3 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt-apps/fotowall_0.9.bb b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
new file mode 100644
index 0000000000..4070ac5548
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Fotowall is a creative tool that allows you to layout your photos or pictures \
+in a personal way. You can add pictures, then resize, move, change colors, text, shadows, etc.."
+
+HOMEPAGE = "http://www.enricoros.com/opensource/fotowall"
+LICENSE = "GPLv2+"
+SECTION = "x11/apps"
+
+DEPENDS = "qt4-x11-free"
+RDEPENDS = "qt4-x11-free"
+
+SRC_URI = "http://qt-apps.org/CONTENT/content-files/71316-Fotowall-0.9.tar.bz2"
+
+S = "${WORKDIR}/Fotowall-${PV}"
+
+inherit qmake2 pkgconfig
+
+do_install() {
+ oe_runmake INSTALL_ROOT=${D} install
+}
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
new file mode 100644
index 0000000000..5f971e8b47
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
+HOMEPAGE = "http://qmmp.ylsoftware.com"
+LICENSE = "GPLv2"
+SECTION = "multimedia"
+
+DEPENDS = "qt4-x11-free"
+RDEPENDS = "qt4-x11-free libmad libvorbis libogg taglib alsa-lib curl"
+
+SRC_URI = "http://qmmp.ylsoftware.com/files/qmmp-0.4.1.tar.bz2"
+
+PARALLEL_MAKE = ""
+
+inherit qmake2 pkgconfig
+
+do_configure_prepend() {
+ # fix qt4 lrelease name
+ sed -i -e 's/lrelease-qt4/lrelease4/' ${S}/qmmp.pro
+
+ # disable the unsupported plugin
+ for plugin in sndfile wavpack ; do
+ sed -i -e "s/$plugin//" ${S}/src/plugins/Input/Input.pro
+ done
+ sed -i -e 's/mms//' ${S}/src/plugins/Transports/Transports.pro
+ sed -i -e 's/srconverter//' ${S}/src/plugins/Effect/Effect.pro
+
+ sed -i -e 's/^CONFIG/#CONFIG/' ${S}/qmmp.pri
+ sed -i -e 's/CONFIG += WITH_ENCA/#CONFIG += WITH_ENCA/' ${S}/qmmp.pri
+}
+
+do_install() {
+ oe_runmake INSTALL_ROOT=${D} install
+}
diff --git a/meta/recipes-qt/qt-apps/quicky_0.4.bb b/meta/recipes-qt/qt-apps/quicky_0.4.bb
new file mode 100644
index 0000000000..ece8ead926
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/quicky_0.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A simple note-taking application with Wiki-style syntax and behaviour"
+HOMEPAGE = "http://qt-apps.org/content/show.php/Quicky?content=80325"
+LICENSE = "GPLv2+"
+SECTION = "x11/apps"
+
+DEPENDS = "qt4-x11-free"
+RDEPENDS = "qt4-x11-free"
+
+SRC_URI = "http://qt-apps.org/CONTENT/content-files/80325-quicky-0.4.tar.gz"
+
+inherit qmake2 pkgconfig
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${PN} ${D}${bindir}
+}