aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-dtb.inc10
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.34.bb2
3 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-dtb.inc b/meta/recipes-kernel/linux/linux-dtb.inc
index eb894562b3..7ec75848dd 100644
--- a/meta/recipes-kernel/linux/linux-dtb.inc
+++ b/meta/recipes-kernel/linux/linux-dtb.inc
@@ -5,12 +5,12 @@ KERNEL_DEVICETREE_FLAGS = "-R 8 -p 0x3000"
python __anonymous () {
import bb
- devicetree = bb.data.getVar("KERNEL_DEVICETREE", d, 1) or ''
+ devicetree = d.getVar("KERNEL_DEVICETREE", 1) or ''
if devicetree:
- depends = bb.data.getVar("DEPENDS", d, 1)
- bb.data.setVar("DEPENDS", "%s dtc-native" % depends, d)
- packages = bb.data.getVar("PACKAGES", d, 1)
- bb.data.setVar("PACKAGES", "%s kernel-devicetree" % packages, d)
+ depends = d.getVar("DEPENDS", 1)
+ d.setVar("DEPENDS", "%s dtc-native" % depends)
+ packages = d.getVar("PACKAGES", 1)
+ d.setVar("PACKAGES", "%s kernel-devicetree" % packages)
}
do_install_append() {
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
index d92a902a9a..26423255c7 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
@@ -27,7 +27,7 @@ python __anonymous () {
import bb, re, string
kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
- bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
+ d.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype)
}
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
index 4891463c03..cbcfa56fec 100644
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
@@ -33,7 +33,7 @@ python __anonymous () {
import bb, re, string
kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
- bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
+ d.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype)
}
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"