aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_git.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_git.bb b/meta/recipes-kernel/sysprof/sysprof_git.bb
index 2b0fbec732..6324d20f65 100644
--- a/meta/recipes-kernel/sysprof/sysprof_git.bb
+++ b/meta/recipes-kernel/sysprof/sysprof_git.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://src/sp-application.c;endline=17;md5=40e55577ef122c88fe20052acda64875"
-inherit gnomebase gettext
+inherit gnomebase gettext systemd
DEPENDS = "glib-2.0"
@@ -13,6 +13,7 @@ PV = "3.20.0+git${SRCPV}"
SRC_URI = "git://git.gnome.org/sysprof \
file://define-NT_GNU_BUILD_ID.patch \
+ file://0001-configure-Add-option-to-enable-disable-polkit.patch \
file://0001-Disable-check-for-polkit-for-UI.patch \
file://0001-Avoid-building-docs.patch \
file://0001-callgraph-Use-U64_TO_POINTER.patch \
@@ -27,9 +28,12 @@ EXTRA_OECONF = "--enable-compile-warnings"
PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
+PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit dbus"
-FILES_${PN} += "${datadir}/icons/ ${libdir}/libsysprof*"
+FILES_${PN} += "${datadir}/icons/ ${libdir}/libsysprof* ${datadir}/dbus-1/"
FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'sysprof2.service', '', d)}"
+
# We do not yet work for aarch64.
COMPATIBLE_HOST = "^(?!aarch64).*"