summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-control_0.87.bb19
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_0.5.bb22
-rw-r--r--meta/recipes-kernel/lttng/lttng-viewer_0.8.84.bb22
3 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-control_0.87.bb b/meta/recipes-kernel/lttng/lttng-control_0.87.bb
new file mode 100644
index 0000000000..da6a6c6e5e
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-control_0.87.bb
@@ -0,0 +1,19 @@
+SECTION = "devel"
+DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
+extract program execution details from the Linux operating system and \
+interpret them."
+LICENSE = "GPL"
+
+PR = "r0"
+
+LTTDATE = "09062010"
+
+SRC_URI = "http://ltt.polymtl.ca/files/lttng/ltt-control-${PV}-${LTTDATE}.tar.gz"
+
+S = "${WORKDIR}/ltt-control-${PV}-${LTTDATE}"
+
+inherit autotools
+
+export KERNELDIR="${STAGING_KERNEL_DIR}"
+
+FILES_${PN} += "${datadir}/ltt-control/facilities/*"
diff --git a/meta/recipes-kernel/lttng/lttng-ust_0.5.bb b/meta/recipes-kernel/lttng/lttng-ust_0.5.bb
new file mode 100644
index 0000000000..4214423f1c
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_0.5.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "The LTTng Userspace Tracer (UST) is a library accompanied by a set of tools to trace userspace code"
+HOMEPAGE = "http://lttng.org/ust"
+BUGTRACKER = "n/a"
+
+# In the source directory, doc/manual/ust.html says ustctl/libustcmd/ustd are
+# licensed as GPL v2, but the source codes of ustctl/libustcmd/ustd have a
+# LGPLv2.1+ header; the files in snprintf/ have a BSD header.
+LICENSE = "LGPV2.1+ & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7d50af17ae17a349e5a8b77852e6395b \
+ file://ustctl/ustctl.c;endline=16;md5=eceeaab8a5574f24d62f7950b9d1adf4 \
+ file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
+
+DEPENDS = "liburcu"
+
+PR = "r0"
+
+SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz"
+
+S = "${WORKDIR}/ust-${PV}"
+
+inherit autotools
+
diff --git a/meta/recipes-kernel/lttng/lttng-viewer_0.8.84.bb b/meta/recipes-kernel/lttng/lttng-viewer_0.8.84.bb
new file mode 100644
index 0000000000..a1786071ec
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-viewer_0.8.84.bb
@@ -0,0 +1,22 @@
+SECTION = "devel"
+DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
+extract program execution details from the Linux operating system and \
+interpret them."
+LICENSE = "GPL"
+PR = "r0"
+DEPENDS = "gtk+ pango popt"
+
+ALTNAME = "LinuxTraceToolkitViewer-${PV}-12082007"
+
+SRC_URI = "http://lttng.org/files/packages/${ALTNAME}.tar.gz"
+S = "${WORKDIR}/${ALTNAME}"
+
+inherit autotools
+
+LEAD_SONAME = "liblttvtraceread*"
+
+FILES_${PN} += "\
+ ${libdir}/lttv/plugins/*.so \
+ ${datadir}/LinuxTraceToolkitViewer/facilities/* \
+ ${datadir}/LinuxTraceToolkitViewer/pixmaps/* "
+FILES_${PN}-dbg += "${libdir}/lttv/plugins/.debug/"