aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index 08dd81569c..ba4d85eda4 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -33,27 +33,12 @@ do_install_append () {
# install depmod.d file for search/ dir
install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
-
- if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
- find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
- find testsuite -name *.ko -exec rm -f {} \;
- fi
}
do_compile_prepend() {
sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status
}
-do_compile_ptest () {
- oe_runmake buildtest-TESTS rootfs
-}
-
-do_install_ptest () {
- install testmodule.tar ${D}${PTEST_PATH}
-}
-
-INSANE_SKIP_${PN}-ptest = "arch"
-
inherit update-alternatives
ALTERNATIVE_PRIORITY = "60"