aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod/ptest.patch8
-rwxr-xr-xmeta/recipes-kernel/kmod/kmod/run-ptest4
2 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/ptest.patch b/meta/recipes-kernel/kmod/kmod/ptest.patch
index c6479b2fb5..831dbcb909 100644
--- a/meta/recipes-kernel/kmod/kmod/ptest.patch
+++ b/meta/recipes-kernel/kmod/kmod/ptest.patch
@@ -15,10 +15,10 @@ diff -ruN a/Makefile.am b/Makefile.am
+ @for file in $(TESTSUITE); do \
+ install $$file $(DESTDIR)/testsuite; \
+ done;
-+ @cp Makefile $(DESTDIR)
-+ @sed -i 's/^Makefile/_Makefile/' ${DESTDIR}/Makefile
-+ @tar -czf $(DESTDIR)/tools.tgz $(noinst_SCRIPTS) $(noinst_PROGRAMS)
-+ @tar -C testsuite -czf $(DESTDIR)/testsuite.tgz rootfs-pristine .libs
++ @sed -e 's/^Makefile/_Makefile/' < Makefile > $(DESTDIR)/Makefile
++ @$(MKDIR_P) $(DESTDIR)/tools
++ @cp $(noinst_SCRIPTS) $(noinst_PROGRAMS) $(DESTDIR)/tools
++ @cp -r testsuite/rootfs testsuite/.libs $(DESTDIR)/testsuite
+
# ------------------------------------------------------------------------------
# custom release helpers
diff --git a/meta/recipes-kernel/kmod/kmod/run-ptest b/meta/recipes-kernel/kmod/kmod/run-ptest
index fac24fd6e1..37adec3d2f 100755
--- a/meta/recipes-kernel/kmod/kmod/run-ptest
+++ b/meta/recipes-kernel/kmod/kmod/run-ptest
@@ -1,5 +1,3 @@
#!/bin/sh
-tar -xzf tools.tgz
-tar -C testsuite -xzf testsuite.tgz
-make rootfs
+touch testsuite/stamp-rootfs
make -k runtest-TESTS 2>/dev/null| grep -e ^PASS -e ^FAIL