summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kern-tools/kern-tools-native_git.bb')
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb27
1 files changed, 18 insertions, 9 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index c3ded98332..12f1cf516e 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -1,23 +1,32 @@
SUMMARY = "Tools for managing Yocto Project style branched kernels"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=d8d1d729a70cd5f52972f8884b80743d"
+DESCRIPTION = "Powerful set of tools or managing Yocto Linux kernel sources \
+and configuration data. You can use these tools to make a single configuration \
+change, apply multiple patches, or work with your own kernel sources."
+HOMEPAGE = "https://www.yoctoproject.org/"
+LICENSE = "GPL-2.0-only & MIT"
+LIC_FILES_CHKSUM = "\
+ file://tools/kgit;beginline=5;endline=9;md5=9c30e971d435e249624278c3e343e501 \
+ file://Kconfiglib/LICENSE.txt;md5=712177a72a3937909543eda3ad1bfb7c \
+"
DEPENDS = "git-native"
-SRCREV = "a6a6f6e1e738d2ecd26b675e9bec867105703416"
-PR = "r12"
-PV = "0.2+git${SRCPV}"
+SRCREV = "2d01f24bc78256c709728eb3f204491bce13e0e5"
+PV = "0.3+git${SRCPV}"
inherit native
-SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git"
-S = "${WORKDIR}"
+SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;branch=master"
+S = "${WORKDIR}/git"
+
+do_configure() {
+ :
+}
do_compile() {
:
}
do_install() {
- cd ${S}/git
- make DESTDIR=${D}${bindir} install
+ oe_runmake DESTDIR=${D}${bindir} install
}