aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch26
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.1.2.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch b/meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch
new file mode 100644
index 0000000000..d212a55cbb
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/parallel-make-race-fix.patch
@@ -0,0 +1,26 @@
+There is a parallel make build issue in src/egl/drivers/dri2/
+for wayland builds. Can be reproduced with:
+
+$ rm src/egl/drivers/dri2/*.h src/egl/drivers/dri2/platform_wayland.lo
+$ make -C src/egl/ drivers/dri2/platform_wayland.lo
+
+../../../mesa-18.1.2/src/egl/drivers/dri2/platform_wayland.c:50:10: fatal error: linux-dmabuf-unstable-v1-client-protocol.h: No such file or directory
+
+This patch adds the missing dependency.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Upstream-Status: Submitted (https://lists.freedesktop.org/archives/mesa-dev/2018-June/198889.html)
+
+Index: mesa-18.1.2/src/egl/Makefile.am
+===================================================================
+--- mesa-18.1.2.orig/src/egl/Makefile.am
++++ mesa-18.1.2/src/egl/Makefile.am
+@@ -80,6 +80,7 @@ drivers/dri2/linux-dmabuf-unstable-v1-cl
+ if HAVE_PLATFORM_WAYLAND
+ drivers/dri2/linux-dmabuf-unstable-v1-protocol.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+ drivers/dri2/egl_dri2.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
++drivers/dri2/platform_wayland.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+
+ AM_CFLAGS += $(WAYLAND_CLIENT_CFLAGS)
+ libEGL_common_la_LIBADD += $(WAYLAND_CLIENT_LIBS)
diff --git a/meta/recipes-graphics/mesa/mesa_18.1.2.bb b/meta/recipes-graphics/mesa/mesa_18.1.2.bb
index 2c06b1eb7b..9a9a2b2562 100644
--- a/meta/recipes-graphics/mesa/mesa_18.1.2.bb
+++ b/meta/recipes-graphics/mesa/mesa_18.1.2.bb
@@ -8,6 +8,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
file://0006-Use-Python-3-to-execute-the-scripts.patch \
file://0007-dri-i965-Add-missing-time.h-include.patch \
+ file://parallel-make-race-fix.patch \
"
SRC_URI[md5sum] = "a2d4f031eb6bd6111d44d84004476918"