aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.5.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.5.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.5.0.bb b/meta/recipes-graphics/wayland/libinput_1.5.0.bb
new file mode 100644
index 0000000000..3c07b0bcc0
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.5.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Library to handle input devices in Wayland compositors"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
+
+DEPENDS = "libevdev udev mtdev"
+
+SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
+ file://touchpad-serial-synaptics-need-to-fake-new-touches-on-TRIPLETAP.patch \
+"
+SRC_URI[md5sum] = "26030dae25f1ac584b0e428c90473339"
+SRC_URI[sha256sum] = "5a96559385ecfaa30f9e72ea89eb8ebbc97caf68e458f451f4ed62315311081c"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
+PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
+PACKAGECONFIG[gui] = "--enable-event-gui,--disable-event-gui,cairo gtk+3"
+
+UDEVDIR = "`pkg-config --variable=udevdir udev`"
+
+EXTRA_OECONF += "--with-udev-dir=${UDEVDIR}"