summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
new file mode 100644
index 0000000000..a6b30fa831
--- /dev/null
+++ b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Vulkan Header files and API registry"
+DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
+to modern GPUs with low overhead and targeting realtime graphics applications such as \
+games and interactive media. This package contains the development headers \
+for packages wanting to make use of Vulkan."
+HOMEPAGE = "https://www.khronos.org/vulkan/"
+BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
+SECTION = "libs"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
+
+SRCREV = "2bb0a23104ceffd9a28d5b7401f2cee7dae35bb8"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES:${PN} += "${datadir}/vulkan"
+RDEPENDS:${PN} += "python3-core"
+
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"