aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch51
1 files changed, 29 insertions, 22 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch b/meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch
index d32c8f2803..93bcfbf851 100644
--- a/meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch
+++ b/meta/recipes-graphics/vulkan/vulkan-demos/0001-Don-t-build-demos-with-questionably-licensed-data.patch
@@ -1,6 +1,6 @@
-From 55770fb07c42fe410cf8d09f8f5976babc89b9ef Mon Sep 17 00:00:00 2001
-From: Jussi Kukkonen <jussi.kukkonen@intel.com>
-Date: Tue, 4 Jul 2017 17:13:45 +0300
+From 0a27144d43b70121f57f6036514d069ca9d2b971 Mon Sep 17 00:00:00 2001
+From: "Maxin B. John" <maxin.john@intel.com>
+Date: Mon, 30 Jul 2018 17:23:29 +0300
Subject: [PATCH] Don't build demos with questionably licensed data
Some of the models don't have open source compatible licenses:
@@ -9,43 +9,46 @@ resources that are not included.
ssao:
scenerendering:
- Sibenik model, no license found
+ Sibenik model, no license found
deferred:
deferredmultisampling:
deferredshadows:
- armor model, CC-BY-3.0
+ armor model, CC-BY-3.0
vulkanscene:
imgui:
shadowmapping:
- vulkanscene model, no license found
+ vulkanscene model, no license found
indirectdraw:
- plant model, no license found
+ plant model, no license found
hdr:
pbribl:
pbrtexture:
- Require external Vulkan Asset Pack
+ Require external Vulkan Asset Pack
Upstream-Status: Inappropriate [configuration]
+
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
---
- CMakeLists.txt | 13 -------------
- 1 file changed, 13 deletions(-)
+ examples/CMakeLists.txt | 14 --------------
+ 1 file changed, 14 deletions(-)
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4958fff..0f9d3e4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,17 +150,11 @@ set(EXAMPLES
- computeparticles
+diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
+index 8eee3a4..698d3b3 100644
+--- a/examples/CMakeLists.txt
++++ b/examples/CMakeLists.txt
+@@ -47,18 +47,12 @@ set(EXAMPLES
computeshader
+ conservativeraster
debugmarker
- deferred
- deferredmultisampling
- deferredshadows
+ descriptorsets
displacement
distancefieldfonts
dynamicuniformbuffer
@@ -53,32 +56,36 @@ index 4958fff..0f9d3e4 100644
geometryshader
- hdr
- imgui
-- indirectdraw
+- indirectdraw
+ inputattachments
instancing
mesh
- multisampling
-@@ -170,20 +164,14 @@ set(EXAMPLES
+@@ -70,8 +64,6 @@ set(EXAMPLES
parallaxmapping
particlefire
pbrbasic
- pbribl
- pbrtexture
pipelines
+ pipelinestatistics
pushconstants
+@@ -79,15 +71,10 @@ set(EXAMPLES
radialblur
raytracing
+ renderheadless
- scenerendering
screenshot
- shadowmapping
- shadowmappingomni
+- shadowmappingcascade
skeletalanimation
specializationconstants
sphericalenvmapping
- ssao
+ stencilbuffer
subpasses
terraintessellation
- tessellation
-@@ -196,7 +184,6 @@ set(EXAMPLES
+@@ -101,7 +88,6 @@ set(EXAMPLES
texturesparseresidency
triangle
viewportarray
@@ -87,5 +94,5 @@ index 4958fff..0f9d3e4 100644
buildExamples()
--
-2.13.2
+2.4.0