aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_git.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 6397ece6fe..1babcc05a9 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -10,11 +10,19 @@ PV = "9.1.3+git${SRCPV}"
SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa \
file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \
+ file://0001-Add-MESA_EGL_NO_X11_HEADERS-to-defines.patch \
file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
- file://0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch \
file://0004-glsl-fix-builtin_compiler-cross-compilation.patch \
file://0005-fix-out-of-tree-builds-gallium.patch \
file://0006-fix-out-of-tree-egl.patch \
"
S = "${WORKDIR}/git"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}