aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.3.5.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.3.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.3.5.bb b/meta/recipes-graphics/mesa/mesa_17.3.5.bb
new file mode 100644
index 0000000000..3ce7135f28
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.3.5.bb
@@ -0,0 +1,23 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+ file://disable-asm-on-non-gcc.patch \
+ file://Use-Python-3-to-execute-the-scripts.patch \
+ file://0001-Use-wayland-scanner-in-the-path.patch \
+ file://0002-hardware-gloat.patch \
+ file://llvm-config-version.patch \
+ file://0001-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ "
+
+SRC_URI[md5sum] = "bf73288c33cf12abe62045c25e2196b4"
+SRC_URI[sha256sum] = "eb9228fc8aaa71e0205c1481c5b157752ebaec9b646b030d27478e25a6d7936a"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}