aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch65
-rw-r--r--meta/recipes-graphics/mesa/mesa/0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch35
-rw-r--r--meta/recipes-graphics/mesa/mesa/0004-glsl-fix-builtin_compiler-cross-compilation.patch54
-rw-r--r--meta/recipes-graphics/mesa/mesa/0005-fix-out-of-tree-builds-gallium.patch42
-rw-r--r--meta/recipes-graphics/mesa/mesa/0005-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch41
5 files changed, 60 insertions, 177 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch b/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch
deleted file mode 100644
index 76b5a18ede..0000000000
--- a/meta/recipes-graphics/mesa/mesa/0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From e21ce89f7ae6964f196086ff325d79e4a3b5acd8 Mon Sep 17 00:00:00 2001
-From: Jonathan Liu <net147@gmail.com>
-Date: Tue, 4 Jun 2013 06:04:44 -0700
-Subject: [PATCH 1/4] configure: Avoid use of AC_CHECK_FILE for cross compiling
-
-The AC_CHECK_FILE macro can't be used for cross compiling as it will
-result in "error: cannot check for file existence when cross compiling".
-Replace it with the AS_IF macro.
-
-Upstream-Status: Submitted
-http://lists.freedesktop.org/archives/mesa-dev/2013-June/040168.html
-
-Signed-off-by: Jonathan Liu <net147@gmail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- configure.ac | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 70c598e..67b8c40 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1630,8 +1630,8 @@ if test "x$enable_gallium_llvm" = xyes; then
- CLANG_LIBDIR=${LLVM_LIBDIR}
- fi
- CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}
-- AC_CHECK_FILE("$CLANG_RESOURCE_DIR/include/stddef.h",,
-- AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.]))
-+ AS_IF([test ! -f "$CLANG_RESOURCE_DIR/include/stddef.h"],
-+ [AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.])])
- fi
- else
- MESA_LLVM=0
-@@ -1861,7 +1861,7 @@ if test "x$MESA_LLVM" != x0; then
- if test "x$with_llvm_shared_libs" = xyes; then
- dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
-- AC_CHECK_FILE("$LLVM_LIBDIR/lib$LLVM_SO_NAME.so", llvm_have_one_so=yes,)
-+ AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.so"], [llvm_have_one_so=yes])
-
- if test "x$llvm_have_one_so" = xyes; then
- dnl LLVM was built using auto*, so there is only one shared object.
-@@ -1869,8 +1869,8 @@ if test "x$MESA_LLVM" != x0; then
- else
- dnl If LLVM was built with CMake, there will be one shared object per
- dnl component.
-- AC_CHECK_FILE("$LLVM_LIBDIR/libLLVMTarget.so",,
-- AC_MSG_ERROR([Could not find llvm shared libraries:
-+ AS_IF([test ! -f "$LLVM_LIBDIR/libLLVMTarget.so"],
-+ [AC_MSG_ERROR([Could not find llvm shared libraries:
- Please make sure you have built llvm with the --enable-shared option
- and that your llvm libraries are installed in $LLVM_LIBDIR
- If you have installed your llvm libraries to a different directory you
-@@ -1881,7 +1881,7 @@ if test "x$MESA_LLVM" != x0; then
- --enable-opencl
- If you do not want to build with llvm shared libraries and instead want to
- use llvm static libraries then remove these options from your configure
-- invocation and reconfigure.]))
-+ invocation and reconfigure.])])
-
- dnl We don't need to update LLVM_LIBS in this case because the LLVM
- dnl install uses a shared object for each compoenent and we have
---
-1.8.2.1
-
diff --git a/meta/recipes-graphics/mesa/mesa/0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch b/meta/recipes-graphics/mesa/mesa/0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch
index 8a83f4b07b..30a3d98758 100644
--- a/meta/recipes-graphics/mesa/mesa/0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch
+++ b/meta/recipes-graphics/mesa/mesa/0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch
@@ -1,7 +1,7 @@
-From 8d31ae23683394617c49301b039b3a069b9ea436 Mon Sep 17 00:00:00 2001
+From 06c1ba29de8a26fffb73ee99f0fc54c704e9fee4 Mon Sep 17 00:00:00 2001
From: Daniel Stone <daniel@fooishbar.org>
Date: Fri, 24 May 2013 17:20:27 +0100
-Subject: [PATCH 3/4] EGL: Mutate NativeDisplayType depending on config
+Subject: [PATCH 3/5] EGL: Mutate NativeDisplayType depending on config
If we go through ./configure without enabling X11 anywhere, then set the
fallback types for EGL NativeDisplay and friends, rather than assuming
@@ -13,36 +13,39 @@ https://bugs.freedesktop.org/show_bug.cgi?id=64959)
Signed-off-by: Daniel Stone <daniel@fooishbar.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- configure.ac | 5 ++
+ configure.ac | 9 +++
include/EGL/eglplatform.h | 146 -------------------------------------------
include/EGL/eglplatform.h.in | 146 +++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 151 insertions(+), 146 deletions(-)
+ 3 files changed, 155 insertions(+), 146 deletions(-)
delete mode 100644 include/EGL/eglplatform.h
create mode 100644 include/EGL/eglplatform.h.in
diff --git a/configure.ac b/configure.ac
-index 67b8c40..afc3217 100644
+index 2b4a374..d4c7a95 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1499,6 +1499,9 @@ EGL_PLATFORMS="$egl_platforms"
+@@ -1565,12 +1565,20 @@ fi
- if echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1; then
- NEED_WINSYS_XLIB=yes
+ EGL_PLATFORMS="$egl_platforms"
+
++if echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1; then
+ MESA_EGL_NO_X11_HEADERS=0
+else
+ MESA_EGL_NO_X11_HEADERS=1
- fi
++fi
++
AM_CONDITIONAL(HAVE_EGL_PLATFORM_X11, echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1)
AM_CONDITIONAL(HAVE_EGL_PLATFORM_WAYLAND, echo "$egl_platforms" | grep 'wayland' >/dev/null 2>&1)
-@@ -1512,6 +1515,7 @@ AM_CONDITIONAL(HAVE_EGL_DRIVER_GLX, test "x$HAVE_EGL_DRIVER_GLX" != "x")
- AC_SUBST([EGL_NATIVE_PLATFORM])
- AC_SUBST([EGL_PLATFORMS])
- AC_SUBST([EGL_CFLAGS])
+ AM_CONDITIONAL(HAVE_EGL_PLATFORM_DRM, echo "$egl_platforms" | grep 'drm' >/dev/null 2>&1)
+ AM_CONDITIONAL(HAVE_EGL_PLATFORM_FBDEV, echo "$egl_platforms" | grep 'fbdev' >/dev/null 2>&1)
+ AM_CONDITIONAL(HAVE_EGL_PLATFORM_NULL, echo "$egl_platforms" | grep 'null' >/dev/null 2>&1)
+
+AC_SUBST([MESA_EGL_NO_X11_HEADERS])
++
+ AM_CONDITIONAL(HAVE_EGL_DRIVER_DRI2, test "x$HAVE_EGL_DRIVER_DRI2" != "x")
+ AM_CONDITIONAL(HAVE_EGL_DRIVER_GLX, test "x$HAVE_EGL_DRIVER_GLX" != "x")
- AC_ARG_WITH([egl-driver-dir],
- [AS_HELP_STRING([--with-egl-driver-dir=DIR],
-@@ -1991,6 +1995,7 @@ CXXFLAGS="$CXXFLAGS $USER_CXXFLAGS"
+@@ -2042,6 +2050,7 @@ CXXFLAGS="$CXXFLAGS $USER_CXXFLAGS"
dnl Substitute the config
AC_CONFIG_FILES([Makefile
diff --git a/meta/recipes-graphics/mesa/mesa/0004-glsl-fix-builtin_compiler-cross-compilation.patch b/meta/recipes-graphics/mesa/mesa/0004-glsl-fix-builtin_compiler-cross-compilation.patch
deleted file mode 100644
index 460a2748bf..0000000000
--- a/meta/recipes-graphics/mesa/mesa/0004-glsl-fix-builtin_compiler-cross-compilation.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From ab38c97f057f739533a4e1fc9de51ea5f4e6242d Mon Sep 17 00:00:00 2001
-From: Jonathan Liu <net147@gmail.com>
-Date: Sat, 29 Jun 2013 11:37:20 +0200
-Subject: [PATCH 4/4] glsl: fix builtin_compiler cross-compilation
-
-The target libtool is used when building host binaries, which predictably
-doesn't work.
-
-Upstream-Status: Submitted https://bugs.freedesktop.org/show_bug.cgi?id=44618
-Signed-off-by: Jonathan Liu <net147@gmail.com>
-Signed-off-by: Ross Burton <ross.burton@intel.com>
----
- src/glsl/builtin_compiler/Makefile.am | 13 +++++++++++++
- 1 file changed, 13 insertions(+)
-
-diff --git a/src/glsl/builtin_compiler/Makefile.am b/src/glsl/builtin_compiler/Makefile.am
-index e11a17f..8ebe0a2 100644
---- a/src/glsl/builtin_compiler/Makefile.am
-+++ b/src/glsl/builtin_compiler/Makefile.am
-@@ -64,6 +64,8 @@ AM_CXXFLAGS = $(AM_CFLAGS)
- include ../Makefile.sources
-
- noinst_PROGRAMS = builtin_compiler
-+
-+if !CROSS_COMPILING
- noinst_LTLIBRARIES = libglslcore.la libglcpp.la
-
- libglcpp_la_SOURCES = \
-@@ -73,6 +75,7 @@ libglcpp_la_SOURCES = \
- libglslcore_la_SOURCES = \
- $(BUILTIN_COMPILER_GENERATED_CXX_FILES) \
- $(LIBGLSL_FILES)
-+endif
-
- builtin_compiler_SOURCES = \
- $(top_srcdir)/src/mesa/main/hash_table.c \
-@@ -81,4 +84,14 @@ builtin_compiler_SOURCES = \
- $(top_srcdir)/src/mesa/program/symbol_table.c \
- $(BUILTIN_COMPILER_CXX_FILES) \
- $(GLSL_COMPILER_CXX_FILES)
-+
-+if CROSS_COMPILING
-+builtin_compiler_SOURCES += \
-+ $(LIBGLCPP_GENERATED_FILES) \
-+ $(LIBGLCPP_FILES) \
-+ $(BUILTIN_COMPILER_GENERATED_CXX_FILES) \
-+ $(LIBGLSL_FILES)
-+builtin_compiler_CPPFLAGS = $(AM_CPPFLAGS)
-+else
- builtin_compiler_LDADD = libglslcore.la libglcpp.la
-+endif
---
-1.8.2.1
-
diff --git a/meta/recipes-graphics/mesa/mesa/0005-fix-out-of-tree-builds-gallium.patch b/meta/recipes-graphics/mesa/mesa/0005-fix-out-of-tree-builds-gallium.patch
deleted file mode 100644
index 8c5984fd55..0000000000
--- a/meta/recipes-graphics/mesa/mesa/0005-fix-out-of-tree-builds-gallium.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Upstream-Status: Submitted
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 9e31e15ebb0adbf3cc0394c30cbc1ccd2b35a27f Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Fri, 28 Jun 2013 11:44:58 +0100
-Subject: [PATCH] build: fix out-of-tree builds in gallium/auxiliary
-
-The rules were writing files to e.g. util/u_indices_gen.py, but in an
-out-of-tree build this directory doesn't exist in the build directory. So,
-create the directories just in case.
-
-Signed-off-by: Ross Burton <ross.burton@intel.com>
----
- src/gallium/auxiliary/Makefile.am | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
-index f14279b..0c3e7ba 100644
---- a/src/gallium/auxiliary/Makefile.am
-+++ b/src/gallium/auxiliary/Makefile.am
-@@ -38,13 +38,17 @@ libgallium_la_SOURCES += \
- endif
-
- indices/u_indices_gen.c: $(srcdir)/indices/u_indices_gen.py
-+ mkdir --parents indices
- $(AM_V_GEN) $(PYTHON2) $< > $@
-
- indices/u_unfilled_gen.c: $(srcdir)/indices/u_unfilled_gen.py
-+ mkdir --parents indices
- $(AM_V_GEN) $(PYTHON2) $< > $@
-
- util/u_format_srgb.c: $(srcdir)/util/u_format_srgb.py
-+ mkdir --parents util
- $(AM_V_GEN) $(PYTHON2) $< > $@
-
- util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
-+ mkdir --parents util
- $(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
---
-1.7.10.4
-
diff --git a/meta/recipes-graphics/mesa/mesa/0005-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch b/meta/recipes-graphics/mesa/mesa/0005-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch
new file mode 100644
index 0000000000..d86421b767
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0005-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch
@@ -0,0 +1,41 @@
+From 33098ef45e6035f3348040a25641f95c95266103 Mon Sep 17 00:00:00 2001
+From: Brian Paul <brianp@vmware.com>
+Date: Wed, 6 Mar 2013 16:57:20 -0700
+Subject: [PATCH 5/5] llvmpipe: remove the power of two sizeof(struct
+ cmd_block) assertion
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It fails on 32-bit systems (I only tested on 64-bit). Power of two
+size isn't required, so just remove the assertion.
+
+Reviewed-by: José Fonseca <jfonseca@vmware.com>
+
+Upstream-Status: Backport
+http://cgit.freedesktop.org/mesa/mesa/commit/?id=9915636fb8afe75ee2e8e013e4f495a4cb937afb
+---
+ src/gallium/drivers/llvmpipe/lp_scene.c | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/src/gallium/drivers/llvmpipe/lp_scene.c b/src/gallium/drivers/llvmpipe/lp_scene.c
+index e145391..c88bc95 100644
+--- a/src/gallium/drivers/llvmpipe/lp_scene.c
++++ b/src/gallium/drivers/llvmpipe/lp_scene.c
+@@ -76,13 +76,6 @@ lp_scene_create( struct pipe_context *pipe )
+ assert(maxCommandBytes < LP_SCENE_MAX_SIZE);
+ /* We'll also need space for at least one other data block */
+ assert(maxCommandPlusData <= LP_SCENE_MAX_SIZE);
+-
+- /* Ideally, the size of a cmd_block object will be a power of two
+- * in order to avoid wasting space when we allocation them from
+- * data blocks (which are power of two also).
+- */
+- assert(sizeof(struct cmd_block) ==
+- util_next_power_of_two(sizeof(struct cmd_block)));
+ }
+ #endif
+
+--
+1.8.2.1
+