aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa/cross-glsl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa/cross-glsl.patch')
-rw-r--r--meta/recipes-graphics/mesa/mesa/cross-glsl.patch632
1 files changed, 0 insertions, 632 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/cross-glsl.patch b/meta/recipes-graphics/mesa/mesa/cross-glsl.patch
deleted file mode 100644
index 2e7929738d..0000000000
--- a/meta/recipes-graphics/mesa/mesa/cross-glsl.patch
+++ /dev/null
@@ -1,632 +0,0 @@
-Respect CC_FOR_BUILD when building glsl_compiler, so we don't need a
-mesa-dri-glsl-native anymore.
-
-Upstream-Status: Backport (from master)
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-diff --git a/configure.ac b/configure.ac
-index b46f897..3765cd3 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -10,7 +10,7 @@ AC_INIT([Mesa], [9.0.1],
- [https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa])
- AC_CONFIG_AUX_DIR([bin])
- AC_CONFIG_MACRO_DIR([m4])
--AC_CANONICAL_HOST
-+AC_CANONICAL_SYSTEM
- AM_INIT_AUTOMAKE([foreign])
-
- dnl http://people.gnome.org/~walters/docs/build-api.txt
-@@ -24,9 +24,6 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-
- m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-
--LT_PREREQ([2.2])
--LT_INIT([disable-static])
--
- dnl Set internal versions
- OSMESA_VERSION=8
- AC_SUBST([OSMESA_VERSION])
-@@ -45,7 +42,9 @@ LIBKMS_XORG_REQUIRED=1.0.0
- dnl Check for progs
- AC_PROG_CPP
- AC_PROG_CC
-+AX_PROG_CC_FOR_BUILD
- AC_PROG_CXX
-+AX_PROG_CXX_FOR_BUILD
- AM_PROG_CC_C_O
- AM_PROG_AS
- AC_CHECK_PROGS([MAKE], [gmake make])
-@@ -54,6 +53,9 @@ AC_PROG_SED
- AC_PROG_MKDIR_P
- AC_PATH_PROG([MKDEP], [makedepend])
-
-+LT_PREREQ([2.2])
-+LT_INIT([disable-static])
-+
- if test "x$MKDEP" = "x"; then
- AC_MSG_ERROR([makedepend is required to build Mesa])
- fi
-@@ -155,6 +157,21 @@ dnl Cache LDFLAGS and CPPFLAGS so we can add to them and restore later
- _SAVE_LDFLAGS="$LDFLAGS"
- _SAVE_CPPFLAGS="$CPPFLAGS"
-
-+dnl build host compiler macros
-+DEFINES_FOR_BUILD=""
-+AC_SUBST([DEFINES_FOR_BUILD])
-+case "$build_os" in
-+linux*|*-gnu*|gnu*)
-+ DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -D_GNU_SOURCE"
-+ ;;
-+solaris*)
-+ DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -DSVR4"
-+ ;;
-+cygwin*)
-+ DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD"
-+ ;;
-+esac
-+
- dnl Compiler macros
- DEFINES=""
- AC_SUBST([DEFINES])
-@@ -172,6 +189,7 @@ esac
-
- dnl Add flags for gcc and g++
- if test "x$GCC" = xyes; then
-+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -Wall -std=c99"
- CFLAGS="$CFLAGS -Wall -std=c99"
-
- # Enable -Werror=implicit-function-declaration and
-@@ -199,13 +217,16 @@ if test "x$GCC" = xyes; then
- CFLAGS=$save_CFLAGS
-
- # Work around aliasing bugs - developers should comment this out
-+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -fno-strict-aliasing"
- CFLAGS="$CFLAGS -fno-strict-aliasing"
-
- # gcc's builtin memcmp is slower than glibc's
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
-+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -fno-builtin-memcmp"
- CFLAGS="$CFLAGS -fno-builtin-memcmp"
- fi
- if test "x$GXX" = xyes; then
-+ CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -Wall"
- CXXFLAGS="$CXXFLAGS -Wall"
-
- # Enable -fvisibility=hidden if using a gcc that supports it
-@@ -222,10 +243,12 @@ if test "x$GXX" = xyes; then
- CXXFLAGS=$save_CXXFLAGS
-
- # Work around aliasing bugs - developers should comment this out
-+ CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -fno-strict-aliasing"
- CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
-
- # gcc's builtin memcmp is slower than glibc's
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
-+ CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -fno-builtin-memcmp"
- CXXFLAGS="$CXXFLAGS -fno-builtin-memcmp"
- fi
-
-@@ -309,6 +332,14 @@ AC_ARG_ENABLE([debug],
- [enable_debug=no]
- )
- if test "x$enable_debug" = xyes; then
-+ DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -DDEBUG"
-+ if test "x$GCC_FOR_BUILD" = xyes; then
-+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -g"
-+ fi
-+ if test "x$GXX_FOR_BUILD" = xyes; then
-+ CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -g"
-+ fi
-+
- DEFINES="$DEFINES -DDEBUG"
- if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -g"
-@@ -1960,6 +1991,7 @@ AC_CONFIG_FILES([configs/current
- src/gbm/Makefile
- src/gbm/main/gbm.pc
- src/glsl/Makefile
-+ src/glsl/builtin_compiler/Makefile
- src/glsl/glcpp/Makefile
- src/glsl/tests/Makefile
- src/glx/Makefile
-diff --git a/m4/ax_prog_cc_for_build.m4 b/m4/ax_prog_cc_for_build.m4
-new file mode 100644
-index 0000000..6369809
---- /dev/null
-+++ b/m4/ax_prog_cc_for_build.m4
-@@ -0,0 +1,125 @@
-+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_prog_cc_for_build.html
-+# ===========================================================================
-+#
-+# SYNOPSIS
-+#
-+# AX_PROG_CC_FOR_BUILD
-+#
-+# DESCRIPTION
-+#
-+# This macro searches for a C compiler that generates native executables,
-+# that is a C compiler that surely is not a cross-compiler. This can be
-+# useful if you have to generate source code at compile-time like for
-+# example GCC does.
-+#
-+# The macro sets the CC_FOR_BUILD and CPP_FOR_BUILD macros to anything
-+# needed to compile or link (CC_FOR_BUILD) and preprocess (CPP_FOR_BUILD).
-+# The value of these variables can be overridden by the user by specifying
-+# a compiler with an environment variable (like you do for standard CC).
-+#
-+# It also sets BUILD_EXEEXT and BUILD_OBJEXT to the executable and object
-+# file extensions for the build platform, and GCC_FOR_BUILD to `yes' if
-+# the compiler we found is GCC. All these variables but GCC_FOR_BUILD are
-+# substituted in the Makefile.
-+#
-+# LICENSE
-+#
-+# Copyright (c) 2008 Paolo Bonzini <bonzini@gnu.org>
-+#
-+# Copying and distribution of this file, with or without modification, are
-+# permitted in any medium without royalty provided the copyright notice
-+# and this notice are preserved. This file is offered as-is, without any
-+# warranty.
-+
-+#serial 5
-+
-+AU_ALIAS([AC_PROG_CC_FOR_BUILD], [AX_PROG_CC_FOR_BUILD])
-+AC_DEFUN([AX_PROG_CC_FOR_BUILD], [dnl
-+AC_REQUIRE([AC_PROG_CC])dnl
-+AC_REQUIRE([AC_PROG_CPP])dnl
-+AC_REQUIRE([AC_EXEEXT])dnl
-+AC_REQUIRE([AC_CANONICAL_SYSTEM])dnl
-+
-+dnl Use the standard macros, but make them use other variable names
-+dnl
-+pushdef([ac_cv_prog_CPP], ac_cv_build_prog_CPP)dnl
-+pushdef([ac_cv_prog_gcc], ac_cv_build_prog_gcc)dnl
-+pushdef([ac_cv_prog_cc_works], ac_cv_build_prog_cc_works)dnl
-+pushdef([ac_cv_prog_cc_cross], ac_cv_build_prog_cc_cross)dnl
-+pushdef([ac_cv_prog_cc_g], ac_cv_build_prog_cc_g)dnl
-+pushdef([ac_cv_exeext], ac_cv_build_exeext)dnl
-+pushdef([ac_cv_objext], ac_cv_build_objext)dnl
-+pushdef([ac_exeext], ac_build_exeext)dnl
-+pushdef([ac_objext], ac_build_objext)dnl
-+pushdef([CC], CC_FOR_BUILD)dnl
-+pushdef([CPP], CPP_FOR_BUILD)dnl
-+pushdef([CFLAGS], CFLAGS_FOR_BUILD)dnl
-+pushdef([CPPFLAGS], CPPFLAGS_FOR_BUILD)dnl
-+pushdef([LDFLAGS], LDFLAGS_FOR_BUILD)dnl
-+pushdef([host], build)dnl
-+pushdef([host_alias], build_alias)dnl
-+pushdef([host_cpu], build_cpu)dnl
-+pushdef([host_vendor], build_vendor)dnl
-+pushdef([host_os], build_os)dnl
-+pushdef([ac_cv_host], ac_cv_build)dnl
-+pushdef([ac_cv_host_alias], ac_cv_build_alias)dnl
-+pushdef([ac_cv_host_cpu], ac_cv_build_cpu)dnl
-+pushdef([ac_cv_host_vendor], ac_cv_build_vendor)dnl
-+pushdef([ac_cv_host_os], ac_cv_build_os)dnl
-+pushdef([ac_cpp], ac_build_cpp)dnl
-+pushdef([ac_compile], ac_build_compile)dnl
-+pushdef([ac_link], ac_build_link)dnl
-+
-+save_cross_compiling=$cross_compiling
-+save_ac_tool_prefix=$ac_tool_prefix
-+cross_compiling=no
-+ac_tool_prefix=
-+
-+AC_PROG_CC
-+AC_PROG_CPP
-+AC_EXEEXT
-+
-+ac_tool_prefix=$save_ac_tool_prefix
-+cross_compiling=$save_cross_compiling
-+
-+dnl Restore the old definitions
-+dnl
-+popdef([ac_link])dnl
-+popdef([ac_compile])dnl
-+popdef([ac_cpp])dnl
-+popdef([ac_cv_host_os])dnl
-+popdef([ac_cv_host_vendor])dnl
-+popdef([ac_cv_host_cpu])dnl
-+popdef([ac_cv_host_alias])dnl
-+popdef([ac_cv_host])dnl
-+popdef([host_os])dnl
-+popdef([host_vendor])dnl
-+popdef([host_cpu])dnl
-+popdef([host_alias])dnl
-+popdef([host])dnl
-+popdef([LDFLAGS])dnl
-+popdef([CPPFLAGS])dnl
-+popdef([CFLAGS])dnl
-+popdef([CPP])dnl
-+popdef([CC])dnl
-+popdef([ac_objext])dnl
-+popdef([ac_exeext])dnl
-+popdef([ac_cv_objext])dnl
-+popdef([ac_cv_exeext])dnl
-+popdef([ac_cv_prog_cc_g])dnl
-+popdef([ac_cv_prog_cc_cross])dnl
-+popdef([ac_cv_prog_cc_works])dnl
-+popdef([ac_cv_prog_gcc])dnl
-+popdef([ac_cv_prog_CPP])dnl
-+
-+dnl Finally, set Makefile variables
-+dnl
-+BUILD_EXEEXT=$ac_build_exeext
-+BUILD_OBJEXT=$ac_build_objext
-+AC_SUBST(BUILD_EXEEXT)dnl
-+AC_SUBST(BUILD_OBJEXT)dnl
-+AC_SUBST([CFLAGS_FOR_BUILD])dnl
-+AC_SUBST([CPPFLAGS_FOR_BUILD])dnl
-+AC_SUBST([LDFLAGS_FOR_BUILD])dnl
-+])
-diff --git a/m4/ax_prog_cxx_for_build.m4 b/m4/ax_prog_cxx_for_build.m4
-new file mode 100644
-index 0000000..ecf8db9
---- /dev/null
-+++ b/m4/ax_prog_cxx_for_build.m4
-@@ -0,0 +1,109 @@
-+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_prog_cxx_for_build.html
-+# ===========================================================================
-+#
-+# SYNOPSIS
-+#
-+# AX_PROG_CXX_FOR_BUILD
-+#
-+# DESCRIPTION
-+#
-+# This macro searches for a C++ compiler that generates native executables,
-+# that is a C++ compiler that surely is not a cross-compiler. This can be
-+# useful if you have to generate source code at compile-time like for
-+# example GCC does.
-+#
-+# The macro sets the CXX_FOR_BUILD and CXXCPP_FOR_BUILD macros to anything
-+# needed to compile or link (CXX_FOR_BUILD) and preprocess (CXXCPP_FOR_BUILD).
-+# The value of these variables can be overridden by the user by specifying
-+# a compiler with an environment variable (like you do for standard CXX).
-+#
-+# LICENSE
-+#
-+# Copyright (c) 2008 Paolo Bonzini <bonzini@gnu.org>
-+# Copyright (c) 2012 Avionic Design GmbH
-+#
-+# Based on the AX_PROG_CC_FOR_BUILD macro by Paolo Bonzini.
-+#
-+# Copying and distribution of this file, with or without modification, are
-+# permitted in any medium without royalty provided the copyright notice
-+# and this notice are preserved. This file is offered as-is, without any
-+# warranty.
-+
-+#serial 5
-+
-+AU_ALIAS([AC_PROG_CXX_FOR_BUILD], [AX_PROG_CXX_FOR_BUILD])
-+AC_DEFUN([AX_PROG_CXX_FOR_BUILD], [dnl
-+AC_REQUIRE([AX_PROG_CC_FOR_BUILD])dnl
-+AC_REQUIRE([AC_PROG_CXX])dnl
-+AC_REQUIRE([AC_PROG_CXXCPP])dnl
-+AC_REQUIRE([AC_CANONICAL_SYSTEM])dnl
-+
-+dnl Use the standard macros, but make them use other variable names
-+dnl
-+pushdef([ac_cv_prog_CXXCPP], ac_cv_build_prog_CXXCPP)dnl
-+pushdef([ac_cv_prog_gxx], ac_cv_build_prog_gxx)dnl
-+pushdef([ac_cv_prog_cxx_works], ac_cv_build_prog_cxx_works)dnl
-+pushdef([ac_cv_prog_cxx_cross], ac_cv_build_prog_cxx_cross)dnl
-+pushdef([ac_cv_prog_cxx_g], ac_cv_build_prog_cxx_g)dnl
-+pushdef([CXX], CXX_FOR_BUILD)dnl
-+pushdef([CXXCPP], CXXCPP_FOR_BUILD)dnl
-+pushdef([CXXFLAGS], CXXFLAGS_FOR_BUILD)dnl
-+pushdef([CPPFLAGS], CPPFLAGS_FOR_BUILD)dnl
-+pushdef([CXXCPPFLAGS], CXXCPPFLAGS_FOR_BUILD)dnl
-+pushdef([host], build)dnl
-+pushdef([host_alias], build_alias)dnl
-+pushdef([host_cpu], build_cpu)dnl
-+pushdef([host_vendor], build_vendor)dnl
-+pushdef([host_os], build_os)dnl
-+pushdef([ac_cv_host], ac_cv_build)dnl
-+pushdef([ac_cv_host_alias], ac_cv_build_alias)dnl
-+pushdef([ac_cv_host_cpu], ac_cv_build_cpu)dnl
-+pushdef([ac_cv_host_vendor], ac_cv_build_vendor)dnl
-+pushdef([ac_cv_host_os], ac_cv_build_os)dnl
-+pushdef([ac_cxxcpp], ac_build_cxxcpp)dnl
-+pushdef([ac_compile], ac_build_compile)dnl
-+pushdef([ac_link], ac_build_link)dnl
-+
-+save_cross_compiling=$cross_compiling
-+save_ac_tool_prefix=$ac_tool_prefix
-+cross_compiling=no
-+ac_tool_prefix=
-+
-+AC_PROG_CXX
-+AC_PROG_CXXCPP
-+
-+ac_tool_prefix=$save_ac_tool_prefix
-+cross_compiling=$save_cross_compiling
-+
-+dnl Restore the old definitions
-+dnl
-+popdef([ac_link])dnl
-+popdef([ac_compile])dnl
-+popdef([ac_cxxcpp])dnl
-+popdef([ac_cv_host_os])dnl
-+popdef([ac_cv_host_vendor])dnl
-+popdef([ac_cv_host_cpu])dnl
-+popdef([ac_cv_host_alias])dnl
-+popdef([ac_cv_host])dnl
-+popdef([host_os])dnl
-+popdef([host_vendor])dnl
-+popdef([host_cpu])dnl
-+popdef([host_alias])dnl
-+popdef([host])dnl
-+popdef([CXXCPPFLAGS])dnl
-+popdef([CPPFLAGS])dnl
-+popdef([CXXFLAGS])dnl
-+popdef([CXXCPP])dnl
-+popdef([CXX])dnl
-+popdef([ac_cv_prog_cxx_g])dnl
-+popdef([ac_cv_prog_cxx_cross])dnl
-+popdef([ac_cv_prog_cxx_works])dnl
-+popdef([ac_cv_prog_gxx])dnl
-+popdef([ac_cv_prog_CXXCPP])dnl
-+
-+dnl Finally, set Makefile variables
-+dnl
-+AC_SUBST([CXXFLAGS_FOR_BUILD])dnl
-+AC_SUBST([CXXCPPFLAGS_FOR_BUILD])dnl
-+])
-diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
-index 1ecc003..6fb3d2d 100644
---- a/src/glsl/Makefile.am
-+++ b/src/glsl/Makefile.am
-@@ -19,9 +19,7 @@
- # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
- # IN THE SOFTWARE.
-
--
--# builtin_compiler is built before libglsl to generate builtin_function.cpp for libglsl.
--# For this to work, a dummy version of builtin_function.cpp, builtin_stubs.cpp, is used.
-+SUBDIRS = builtin_compiler glcpp
-
- AM_CPPFLAGS = \
- -I$(top_srcdir)/include \
-@@ -38,32 +36,23 @@ AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
-
- include Makefile.sources
-
--noinst_LTLIBRARIES = libglslcommon.la libglsl.la
--noinst_PROGRAMS = glsl_compiler glsl_test builtin_compiler
-+noinst_LTLIBRARIES = libglsl.la
-+noinst_PROGRAMS = glsl_compiler glsl_test
-
--# common sources for builtin_compiler and libglsl
--libglslcommon_la_SOURCES = \
-+libglsl_la_SOURCES = \
- glsl_lexer.ll \
- glsl_parser.cc \
- $(LIBGLSL_FILES) \
-- $(LIBGLSL_CXX_FILES)
--
--libglslcommon_la_LIBADD = glcpp/libglcpp.la
--
--# common sources for builtin_compiler and glsl_compiler
--GLSL2_SOURCES = \
-- $(top_srcdir)/src/mesa/program/hash_table.c \
-- $(top_srcdir)/src/mesa/program/symbol_table.c \
-- $(GLSL_COMPILER_CXX_FILES)
--
--libglsl_la_SOURCES = \
-+ $(LIBGLSL_CXX_FILES) \
- builtin_function.cpp
-
--libglsl_la_LIBADD = libglslcommon.la
-+libglsl_la_LIBADD = glcpp/libglcpp.la
- libglsl_la_LDFLAGS =
-
- glsl_compiler_SOURCES = \
-- $(GLSL2_SOURCES)
-+ $(top_srcdir)/src/mesa/program/hash_table.c \
-+ $(top_srcdir)/src/mesa/program/symbol_table.c \
-+ $(GLSL_COMPILER_CXX_FILES)
-
- glsl_compiler_LDADD = libglsl.la
-
-@@ -76,12 +65,6 @@ glsl_test_SOURCES = \
-
- glsl_test_LDADD = libglsl.la
-
--builtin_compiler_SOURCES = \
-- $(GLSL2_SOURCES) \
-- builtin_stubs.cpp
--
--builtin_compiler_LDADD = libglslcommon.la
--
- # automake <=1.11 and automake >=1.12 have different conventions for naming C++ header files
- # made by yacc. To work with both, we write our own rule rather than using automake's.
- # When (if) we require automake >=1.12 in configure.ac, this can be removed, and we can use
-@@ -89,16 +72,11 @@ builtin_compiler_LDADD = libglslcommon.la
- glsl_parser.cc glsl_parser.h: glsl_parser.yy
- $(AM_V_GEN) $(YACC) -v -o glsl_parser.cc -p "_mesa_glsl_" --defines=glsl_parser.h $<
-
--BUILT_SOURCES = glsl_parser.h builtin_function.cpp
--CLEANFILES = glsl_lexer.cc glsl_parser.cc $(BUILT_SOURCES)
--
--builtin_function.cpp: $(srcdir)/builtins/profiles/* $(srcdir)/builtins/ir/* $(srcdir)/builtins/glsl/* $(srcdir)/builtins/tools/generate_builtins.py $(srcdir)/builtins/tools/texture_builtins.py builtin_compiler$(EXEEXT)
-- $(AM_V_GEN) $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/builtins/tools/generate_builtins.py ./builtin_compiler > builtin_function.cpp || rm -f builtin_function.cpp
--
--glcpp/libglcpp.la:
-- cd glcpp ; $(MAKE) $(AM_MAKEFLAGS)
-+BUILT_SOURCES = glsl_parser.h
-+CLEANFILES = glsl_lexer.cc glsl_parser.cc $(BUILT_SOURCES) builtin_function.cpp
-
--SUBDIRS = glcpp
-+builtin_function.cpp: $(srcdir)/builtins/profiles/* $(srcdir)/builtins/ir/* $(srcdir)/builtins/glsl/* $(srcdir)/builtins/tools/generate_builtins.py $(srcdir)/builtins/tools/texture_builtins.py builtin_compiler/builtin_compiler$(BUILD_EXEEXT)
-+ $(AM_V_GEN) $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/builtins/tools/generate_builtins.py builtin_compiler/builtin_compiler$(BUILD_EXEEXT) > builtin_function.cpp || rm -f builtin_function.cpp
-
- # Provide compatibility with scripts for the old Mesa build system for
- # a while by putting a link to the library in the current directory.
-diff --git a/src/glsl/builtin_compiler/Makefile.am b/src/glsl/builtin_compiler/Makefile.am
-new file mode 100644
-index 0000000..72032b5
---- /dev/null
-+++ b/src/glsl/builtin_compiler/Makefile.am
-@@ -0,0 +1,68 @@
-+# Copyright © 2012 Jon TURNEY
-+# Copyright © 2012 Thierry Reding
-+#
-+# Permission is hereby granted, free of charge, to any person obtaining a
-+# copy of this software and associated documentation files (the "Software"),
-+# to deal in the Software without restriction, including without limitation
-+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+# and/or sell copies of the Software, and to permit persons to whom the
-+# Software is furnished to do so, subject to the following conditions:
-+#
-+# The above copyright notice and this permission notice (including the next
-+# paragraph) shall be included in all copies or substantial portions of the
-+# Software.
-+#
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-+# IN THE SOFTWARE.
-+
-+CC = @CC_FOR_BUILD@
-+CFLAGS = @CFLAGS_FOR_BUILD@
-+CPP = @CPP_FOR_BUILD@
-+CPPFLAGS = @CPPFLAGS_FOR_BUILD@
-+CXX = @CXX_FOR_BUILD@
-+CXXFLAGS = @CXXFLAGS_FOR_BUILD@
-+LD = @LD_FOR_BUILD@
-+LDFLAGS = @LDFLAGS_FOR_BUILD@
-+
-+AM_CFLAGS = \
-+ -I $(top_srcdir)/include \
-+ -I $(top_srcdir)/src/mapi \
-+ -I $(top_srcdir)/src/mesa \
-+ -I $(GLSL_SRCDIR) \
-+ -I $(GLSL_SRCDIR)/glcpp \
-+ $(DEFINES_FOR_BUILD)
-+
-+AM_CXXFLAGS = $(AM_CFLAGS)
-+
-+AM_YFLAGS = -v -d -p "glcpp_parser_"
-+AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
-+
-+include ../Makefile.sources
-+
-+noinst_PROGRAMS = builtin_compiler
-+
-+builtin_compiler_SOURCES = \
-+ $(GLSL_SRCDIR)/glcpp/glcpp-lex.l \
-+ $(GLSL_SRCDIR)/glcpp/glcpp-parse.y \
-+ $(LIBGLCPP_FILES) \
-+ $(GLSL_SRCDIR)/glsl_lexer.ll \
-+ $(GLSL_SRCDIR)/glsl_parser.cc \
-+ $(LIBGLSL_FILES) \
-+ $(LIBGLSL_CXX_FILES) \
-+ $(top_srcdir)/src/mesa/program/hash_table.c \
-+ $(top_srcdir)/src/mesa/program/symbol_table.c \
-+ $(GLSL_COMPILER_CXX_FILES) \
-+ builtin_stubs.cpp
-+
-+BUILT_SOURCES = \
-+ glcpp-lex.c \
-+ glcpp-parse.c \
-+ glcpp-parse.h \
-+ glsl_lexer.cc
-+
-+CLEANFILES = $(BUILT_SOURCES)
-diff --git a/src/glsl/builtin_compiler/builtin_stubs.cpp b/src/glsl/builtin_compiler/builtin_stubs.cpp
-new file mode 100644
-index 0000000..dfa5d32
---- /dev/null
-+++ b/src/glsl/builtin_compiler/builtin_stubs.cpp
-@@ -0,0 +1,39 @@
-+/*
-+ * Copyright © 2010 Intel Corporation
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the "Software"),
-+ * to deal in the Software without restriction, including without limitation
-+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+ * and/or sell copies of the Software, and to permit persons to whom the
-+ * Software is furnished to do so, subject to the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the next
-+ * paragraph) shall be included in all copies or substantial portions of the
-+ * Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-+ * DEALINGS IN THE SOFTWARE.
-+ */
-+
-+#include <stdio.h>
-+#include "glsl_parser_extras.h"
-+
-+/* A dummy file. When compiling prototypes, we don't care about builtins.
-+ * We really don't want to half-compile builtin_functions.cpp and fail, though.
-+ */
-+void
-+_mesa_glsl_release_functions(void)
-+{
-+}
-+
-+void
-+_mesa_glsl_initialize_functions(_mesa_glsl_parse_state *state)
-+{
-+ (void) state;
-+}
-diff --git a/src/glsl/builtin_stubs.cpp b/src/glsl/builtin_stubs.cpp
-deleted file mode 100644
-index dfa5d32..0000000
---- a/src/glsl/builtin_stubs.cpp
-+++ /dev/null
-@@ -1,39 +0,0 @@
--/*
-- * Copyright © 2010 Intel Corporation
-- *
-- * Permission is hereby granted, free of charge, to any person obtaining a
-- * copy of this software and associated documentation files (the "Software"),
-- * to deal in the Software without restriction, including without limitation
-- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
-- * and/or sell copies of the Software, and to permit persons to whom the
-- * Software is furnished to do so, subject to the following conditions:
-- *
-- * The above copyright notice and this permission notice (including the next
-- * paragraph) shall be included in all copies or substantial portions of the
-- * Software.
-- *
-- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-- * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-- * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-- * DEALINGS IN THE SOFTWARE.
-- */
--
--#include <stdio.h>
--#include "glsl_parser_extras.h"
--
--/* A dummy file. When compiling prototypes, we don't care about builtins.
-- * We really don't want to half-compile builtin_functions.cpp and fail, though.
-- */
--void
--_mesa_glsl_release_functions(void)
--{
--}
--
--void
--_mesa_glsl_initialize_functions(_mesa_glsl_parse_state *state)
--{
-- (void) state;
--}