aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fstests/fstests_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fstests/fstests_git.bb')
-rw-r--r--meta/recipes-graphics/fstests/fstests_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fstests/fstests_git.bb b/meta/recipes-graphics/fstests/fstests_git.bb
new file mode 100644
index 0000000000..e1623f4935
--- /dev/null
+++ b/meta/recipes-graphics/fstests/fstests_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Various benchmarning tests for X"
+HOMEPAGE = "http://www.o-hand.com"
+SECTION = "devel"
+LICENSE = "Zlib"
+DEPENDS = "pango libxext libxft virtual/libx11 gtk+"
+
+SRCREV = "218b99d82b56011e3f1b909e6baf22ce25af6334"
+PV = "0.1+git${SRCPV}"
+PR = "r0"
+
+
+SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
+ file://dso_linking_change_build_fix.patch"
+
+S = "${WORKDIR}/git/tests"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ find . -name "test-*" -type f -perm -755 -exec install -m 0755 {} ${D}${bindir} \;
+}
+
+
+LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac6cc180f7655"