aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.6.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.bb32
1 files changed, 12 insertions, 20 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.bb b/meta/recipes-graphics/freetype/freetype_2.6.bb
index 70599c67a9..17ab1c87a7 100644
--- a/meta/recipes-graphics/freetype/freetype_2.6.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.6.bb
@@ -13,48 +13,40 @@ LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=c017ff17fc6f0794adf93db5559ccd56
SECTION = "libs"
-SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://use-right-libtool.patch"
SRC_URI[md5sum] = "5682890cb0267f6671dd3de6eabd3e69"
SRC_URI[sha256sum] = "8469fb8124764f85029cc8247c31e132a2c5e51084ddce2a44ea32ee4ae8347e"
BINCONFIG = "${bindir}/freetype-config"
-inherit autotools-brokensep pkgconfig binconfig-disabled multilib_header
+inherit autotools pkgconfig binconfig-disabled multilib_header
-LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
-EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
-EXTRA_OEMAKE_class-native = ""
-EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
+EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
-
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "zlib"
+PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
# This results in a circular dependency so enabling is non-trivial
PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
do_configure() {
- cd builds/unix
+ # Need this because although the autotools infrastructure is in
+ # builds/unix the configure script get written to ${S}, so we can't
+ # just use AUTOTOOLS_SCRIPT_PATH.
+ cd ${S}/builds/unix
libtoolize --force --copy
aclocal -I .
gnu-configize --force
autoconf
- cd ${S}
- oe_runconf
-}
-
-do_configure_class-native() {
- (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+ cd ${B}
oe_runconf
}
-do_compile_prepend() {
- ${BUILD_CC} -o objs/apinames src/tools/apinames.c
-}
-
do_install_append() {
oe_multilib_header freetype2/config/ftconfig.h
}
BBCLASSEXTEND = "native"
-