summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter/enable_tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter/enable_tests.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests.patch b/meta/recipes-graphics/clutter/clutter/enable_tests.patch
new file mode 100644
index 0000000000..f4af7c94f6
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests.patch
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2009-11-30 17:39:46.000000000 +0000
++++ git/tests/interactive/Makefile.am 2009-11-30 17:42:30.000000000 +0000
+@@ -88,7 +88,7 @@
+
+ common_ldadd = $(top_builddir)/clutter/libclutter-@CLUTTER_WINSYS@-@CLUTTER_API_VERSION@.la
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = test-main.c $(UNIT_TESTS)
+ test_interactive_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c 2009-11-30 17:39:46.000000000 +0000
++++ git/tests/interactive/test-actors.c 2009-11-30 17:43:03.000000000 +0000
+@@ -178,7 +178,7 @@
+ oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+ oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+
+- file = g_build_filename (TESTS_DATADIR, "redhand.png", NULL);
++ file = g_build_filename (TESTS_DATADIR, "/usr/share/clutter/redhand.png", NULL);
+ real_hand = clutter_texture_new_from_file (file, &error);
+ if (real_hand == NULL)
+ g_error ("image load failed: %s", error->message);