aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
new file mode 100644
index 0000000000..cfb50dc703
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
@@ -0,0 +1,28 @@
+Even with introspection disabled clutter-box2d would try to install the gir
+files.
+This patch ignored the while introspection related section of the Makefile if
+introspection is disabled.
+
+JL 28/03/11
+josh@linux.intel.com
+
+Index: clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+===================================================================
+--- clutter-box2d-0.10.0.orig/clutter-box2d/Makefile.am
++++ clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+@@ -41,6 +41,8 @@ EXTRA_DIST = \
+
+ BUILT_GIRSOURCES =
+
++if HAVE_INTROSPECTION
++
+ ClutterBox2D-@CLUTTER_BOX2D_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libclutter-box2d-@CLUTTER_BOX2D_API_VERSION@.la
+ $(QUIET_GEN)$(INTROSPECTION_SCANNER) -v \
+ --namespace ClutterBox2D --nsversion=@CLUTTER_BOX2D_API_VERSION@ \
+@@ -70,3 +72,5 @@ typelibs_DATA = $(BUILT_GIRSOURCES:.gir=
+
+ CLEANFILES=
+ CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
++
++endif
+\ No newline at end of file