summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb b/meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb
new file mode 100644
index 0000000000..cba15e947e
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.14.01.bb
@@ -0,0 +1,29 @@
+SUMMARY = "System load testing utility"
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
+SRCREV = "597da6154263c9317291f2dd0ed71a8ff1e8b2dc"
+S = "${WORKDIR}/git"
+
+DEPENDS = "coreutils-native"
+
+PROVIDES = "stress"
+RPROVIDES:${PN} = "stress"
+RREPLACES:${PN} = "stress"
+RCONFLICTS:${PN} = "stress"
+
+inherit bash-completion
+
+do_compile:prepend() {
+ mkdir -p configs
+ touch configs/HAVE_APPARMOR
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+ ln -s stress-ng ${D}${bindir}/stress
+}