summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/minicom/minicom-2.6.1
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/minicom/minicom-2.6.1')
-rw-r--r--meta/recipes-extended/minicom/minicom-2.6.1/gcc4-scope.patch46
-rw-r--r--meta/recipes-extended/minicom/minicom-2.6.1/minicom_fix_for_automake-1.12.patch21
-rw-r--r--meta/recipes-extended/minicom/minicom-2.6.1/rename-conflicting-functions.patch15
3 files changed, 0 insertions, 82 deletions
diff --git a/meta/recipes-extended/minicom/minicom-2.6.1/gcc4-scope.patch b/meta/recipes-extended/minicom/minicom-2.6.1/gcc4-scope.patch
deleted file mode 100644
index 0660cb0c15..0000000000
--- a/meta/recipes-extended/minicom/minicom-2.6.1/gcc4-scope.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Upstream-Status: Inappropriate [others]
-
---- minicom-2.1/src/window.c.orig 2006-06-14 17:49:53.000000000 +0200
-+++ minicom-2.1/src/window.c 2006-06-14 17:50:14.000000000 +0200
-@@ -62,7 +62,7 @@
- static char *CS, *SF, *SR, *VB, *BL;
- static char *VE, *VI, *KS, *KE;
- static char *CD, *CL, *IC, *DC;
--static char *BC, *CR, *NL;
-+static char *mcBC, *CR, *NL;
- #if ST_LINE
- static char *TS, *FS, *DS;
- #endif
-@@ -322,8 +322,8 @@
- else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
- outstr(NL);
- #endif
-- else if (BC != CNULL && y == cury && x == curx - 1)
-- outstr(BC);
-+ else if (mcBC != CNULL && y == cury && x == curx - 1)
-+ outstr(mcBC);
- else
- outstr(tgoto(CM, x, y));
- curx = x;
-@@ -1918,7 +1918,7 @@
- CL = tgetstr("cl", &_tptr);
- IC = tgetstr("ic", &_tptr);
- DC = tgetstr("dc", &_tptr);
-- BC = tgetstr("bc", &_tptr);
-+ mcBC = tgetstr("bc", &_tptr);
- CR = tgetstr("cr", &_tptr);
- NL = tgetstr("nl", &_tptr);
- AC = tgetstr("ac", &_tptr);
-@@ -1967,10 +1967,10 @@
- _has_am = tgetflag("am");
- _mv_standout = tgetflag("ms");
- if (tgetflag("bs")) {
-- if (BC == CNULL) BC = "\b";
-+ if (mcBC == CNULL) mcBC = "\b";
- }
- else
-- BC = CNULL;
-+ mcBC = CNULL;
-
- /* Special IBM box-drawing characters */
- D_UL = 201;
diff --git a/meta/recipes-extended/minicom/minicom-2.6.1/minicom_fix_for_automake-1.12.patch b/meta/recipes-extended/minicom/minicom-2.6.1/minicom_fix_for_automake-1.12.patch
deleted file mode 100644
index aba6298bba..0000000000
--- a/meta/recipes-extended/minicom/minicom-2.6.1/minicom_fix_for_automake-1.12.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Upstream-Status: Pending
-
-This patch fixes following issue with automake 1.12
-
-| configure.in:193: error: automatic de-ANSI-fication support has been removed
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-2012/05/03
-
-Index: minicom-2.6.1/configure.in
-===================================================================
---- minicom-2.6.1.orig/configure.in
-+++ minicom-2.6.1/configure.in
-@@ -190,7 +190,6 @@ AC_CHECK_HEADERS(stdarg.h varargs.h term
-
- dnl Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
--AM_C_PROTOTYPES
- AC_TYPE_UID_T
- AC_TYPE_MODE_T
- AC_TYPE_PID_T
diff --git a/meta/recipes-extended/minicom/minicom-2.6.1/rename-conflicting-functions.patch b/meta/recipes-extended/minicom/minicom-2.6.1/rename-conflicting-functions.patch
deleted file mode 100644
index 1a50f18856..0000000000
--- a/meta/recipes-extended/minicom/minicom-2.6.1/rename-conflicting-functions.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Upstream-Status: Pending
-
---- minicom-2.3/src/minicom.c-orig 2009-06-08 14:49:07.000000000 +0200
-+++ minicom-2.3/src/minicom.c 2009-06-08 14:50:23.000000000 +0200
-@@ -63,6 +63,10 @@
- }
- #endif /*DEBUG*/
-
-+#ifdef __USE_GNU
-+#define getline minicom_getline
-+#endif
-+
- /*
- * Sub - menu's.
- */