summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch')
-rw-r--r--meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch b/meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch
new file mode 100644
index 0000000000..9b610caa78
--- /dev/null
+++ b/meta/recipes-extended/mc/files/fix_for_automake_1.11.2.patch
@@ -0,0 +1,69 @@
+Upstream-Status: Pending
+
+As Nitin said, "automake version 1.11.2 has made use of dir variables
+more strict, the pkglibexec var can not have SCRIPTS suffix. Using pkgdata
+instead."
+
+Fixes this error:
+| contrib/Makefile.am:10: `pkglibexecdir' is not a legitimate directory for `SCRIPTS'
+| autoreconf: automake failed with exit status: 1
+NOTE: package mc-4.8.1-r0: task do_configure: Failed
+
+Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+Wed Jan 4 17:04:47 CST 2012
+
+diff -Nru mc-4.8.1.orig//contrib/Makefile.am mc-4.8.1/contrib/Makefile.am
+--- mc-4.8.1.orig//contrib/Makefile.am 2011-11-30 15:44:40.000000000 +0800
++++ mc-4.8.1/contrib/Makefile.am 2012-01-04 17:03:16.926911680 +0800
+@@ -7,7 +7,7 @@
+ SCRIPTS_IN = mc.csh.in mc.sh.in mc-wrapper.csh.in mc-wrapper.sh.in
+ SCRIPTS_OUT = mc.csh mc.sh mc-wrapper.csh mc-wrapper.sh
+
+-pkglibexec_SCRIPTS = $(SCRIPTS_OUT)
++pkgdata_SCRIPTS = $(SCRIPTS_OUT)
+ pkglibexecdir = $(libexecdir)/@PACKAGE@
+
+ cfgdir = $(sysconfdir)/@PACKAGE@
+diff -Nru mc-4.8.1.orig//contrib/Makefile.in mc-4.8.1/contrib/Makefile.in
+--- mc-4.8.1.orig//contrib/Makefile.in 2011-12-13 18:10:52.000000000 +0800
++++ mc-4.8.1/contrib/Makefile.in 2012-01-04 17:03:16.926911680 +0800
+@@ -112,7 +112,7 @@
+ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+ am__installdirs = "$(DESTDIR)$(pkglibexecdir)" "$(DESTDIR)$(cfgdir)"
+-SCRIPTS = $(pkglibexec_SCRIPTS)
++SCRIPTS = $(pkgdata_SCRIPTS)
+ AM_V_GEN = $(am__v_GEN_$(V))
+ am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+ am__v_GEN_0 = @echo " GEN " $@;
+@@ -372,7 +372,7 @@
+ noinst_DATA = README.xterm
+ SCRIPTS_IN = mc.csh.in mc.sh.in mc-wrapper.csh.in mc-wrapper.sh.in
+ SCRIPTS_OUT = mc.csh mc.sh mc-wrapper.csh mc-wrapper.sh
+-pkglibexec_SCRIPTS = $(SCRIPTS_OUT)
++pkgdata_SCRIPTS = $(SCRIPTS_OUT)
+ cfgdir = $(sysconfdir)/@PACKAGE@
+ cfg_DATA = \
+ $(LIBFILES_ADD)
+@@ -417,10 +417,10 @@
+ $(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ $(am__aclocal_m4_deps):
+-install-pkglibexecSCRIPTS: $(pkglibexec_SCRIPTS)
++install-pkglibexecSCRIPTS: $(pkgdata_SCRIPTS)
+ @$(NORMAL_INSTALL)
+ test -z "$(pkglibexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pkglibexecdir)"
+- @list='$(pkglibexec_SCRIPTS)'; test -n "$(pkglibexecdir)" || list=; \
++ @list='$(pkgdata_SCRIPTS)'; test -n "$(pkglibexecdir)" || list=; \
+ for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ if test -f "$$d$$p"; then echo "$$d$$p"; echo "$$p"; else :; fi; \
+@@ -445,7 +445,7 @@
+
+ uninstall-pkglibexecSCRIPTS:
+ @$(NORMAL_UNINSTALL)
+- @list='$(pkglibexec_SCRIPTS)'; test -n "$(pkglibexecdir)" || exit 0; \
++ @list='$(pkgdata_SCRIPTS)'; test -n "$(pkglibexecdir)" || exit 0; \
+ files=`for p in $$list; do echo "$$p"; done | \
+ sed -e 's,.*/,,;$(transform)'`; \
+ test -n "$$list" || exit 0; \