summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libaio/libaio_0.3.112.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libaio/libaio_0.3.112.bb')
-rw-r--r--meta/recipes-extended/libaio/libaio_0.3.112.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-extended/libaio/libaio_0.3.112.bb b/meta/recipes-extended/libaio/libaio_0.3.112.bb
new file mode 100644
index 0000000000..b3606474a5
--- /dev/null
+++ b/meta/recipes-extended/libaio/libaio_0.3.112.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Asynchronous I/O library"
+DESCRIPTION = "Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE = "http://lse.sourceforge.net/io/aio.html"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
+
+SRC_URI = "git://pagure.io/libaio.git;protocol=https \
+ file://00_arches.patch \
+ file://libaio_fix_for_mips_syscalls.patch \
+ file://system-linkage.patch \
+ "
+SRCREV = "d025927efa75a0d1b46ca3a5ef331caa2f46ee0e"
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+BBCLASSEXTEND = "native nativesdk"